Casper Remote - SSH fails to authenticate

New Contributor
Sending Wake On LAN command... Opening SSH Connection to Authenticating... Authenticating...

This question has been proposed before, but my typical actions for resolution are all failing.

  1. I've had this fail when the hostname on the machine hadn't updated properly. (check)

  2. I've had this happen randomly when even though 'Remote Login' and 'Remote Management' are both checked in the sharing menu, ssh and screen sharing fail, this is typically resolved by toggling the check box. (check)

I've also been able to verify that I can login in as a local and domain user via ssh to the machine. So SSH would appear to be working

  1. I've also seen the issue described here, where upgrading whole OS versions, screws with <501 accounts. (As is our Management account)

I've killed the jamf binary, deleted the admin account, deleted the record from JSS, re-enrolled the machine, and even narfled the Garthok.

But it still returns:

Authenticating... Authenticating...

I don't know where else to look at this point - Any Suggestions?

Edit: If anyones wondering why the number list restarts back at 1 I typed 3, but it's parsed back to 1.
inb4 pics or didn't happen.



Contributor III

@zerocool This usually happens when the management account credentials saved in the inventory record for this or any Mac showing this behavior are incorrect.

Can you try just verifying the management account credentials are correct and then see if it will authenticate?

New Contributor

Yes, I have manually assigned our local admin account (verified the login on the machine and via ssh) in JSS as a management account, and have also tried reassigning through JAMF recon.

Previously this /has/ been successful, but it's not the ticket this time around.

Contributor III

If you can manually ssh in via terminal with the same credentials and that works fine.. i would delete the inventory record of that mac and re-enroll. If it's all or a bulk of your Macs, I would contact JAMF Support since you've tried most steps to resolve this already.

New Contributor II

I ran into this a few months ago. I got the same response when I tried to use Casper Remote into two of our labs. I could successfully SSH into the computers using the JAMF management account but for some reason Casper Remote would get the error.

For me the fix was to run the delete account command on each computer and remove the JAMF management account.

jamf deleteAccount -username <management account username>

then enroll the computer with JAMF again.

New Contributor II

Stumbled onto this as well.
Computers made check-in's and also sent inventory updates but if I wanted to "hard" push something they just kept pending on "Authenticating..." I tried Network scanning via recon but some computers skipped this and still the problem occurred, so I took the IP-s and enrolled them one-by-one with remote enrollment in recon and this solved my problem.