Casper Suite 9.82

mm2270
Legendary Contributor II

Just saw the email that 9.82 is now out. I took a look at the Release notes and it seems like several good fixes made it into this version. A couple that I noted-

[D-009724] When upgrading to a Casper Suite version that uses the new jamf binary location, launch services no longer fail to automatically use the new binary location if the computer loses its connection to the JSS during the upgrade. [D-009686] When upgrading the JSS to v9.8, the “Log out users after” option is no longer enabled by default in the Login Window payload of an OS X configuration profile.

There's also this one, under Deprecations:

• Policy status determined by checking script output for “error” and “fail”—The JSS no longer determines the status of a policy by checking script output for the words “error” and “fail”. As of v9. 82, the JSS now only uses error codes to determine the status of a policy.

Thank you JAMF for finally removing this functionality! I no longer have to worry about policy scripts causing false failures to be logged (once we upgrade that is)

Anything else in the notes that are important fixes for some of you out there?

51 REPLIES 51

jhbush
Valued Contributor II

I think I ended up making a custom profile to get this to stick.

askForPassword=1, askForPasswordDelay=0, idleTime=600

com.apple.screensaver

emily
Valued Contributor III

Heard back from my TAM. Defect for the "immediately" setting is D-010036.

He also said:

If you set the time delay to any other setting other than immediately, the config profile works fine.

Aziz
Valued Contributor

@emilykausalik Some of our Finder settings are also not being applied. Specifically, hiding the "Shutdown" button. I'll contact my TAM when I have time.

CasperSally
Valued Contributor II

I can confirm in 9.81 I had to use custom profile too for screensaver/immediately.

{tokenRemovalAction=0, askForPassword=1, askForPasswordDelay=0.0}

bpavlov
Honored Contributor

FWIW, on 9.81 and OS X 10.10.5, the setting immediately is correct.

msnowdon
Contributor

Ive been setting it in the Security & Privacy payload and it still seems to be working after upgrading to 9.82 but my clients are still on Yosemite.

krispayne
Contributor

@aporlebeke @adamcodega

Mass update is super nice (although in the Execute command, not as cool)

I also thought that we would be able to block the updates.

cdenesha
Valued Contributor II

Has anyone tested Mass Update with the Download Only option? In my testing, a message pops up after the download that says 'iOS 9.2 will begin installing in 10 seconds' for both 'Download Only' and 'Download and Install and Restart', so I don't know what the expected outcome is supposed to be.

cdenesha
Valued Contributor II

From my TAM:

A Product Issue was just created that describes the behavior you are seeing. We have this noted as D-010049.

Edit: To be more specific, The Download Only option is also Installing.

chris_kemp
Contributor III

I happened to look into the screensaver passcode delay issue this morning, before seeing this post - have y'all actually confirmed that the delay is not being enforced, or are you going off of the Security window?

Reason I ask: I tested by removing the profiles from my machine, which previously showed "Immediately" for passcode requirement - and when I did, the UI defaulted to my old MCX setting which was 5 seconds.

After reapplying the profiles, it never reflected the change in timing – it still said 5 seconds.

However, I then removed the profiles again, changed the time setting to 5 minutes, and saw the UI update accordingly. When I then reapplied the profiles it still said 5 minutes - but when testing actual functionality, it did in fact ask me for a password after only a few seconds when the screensaver kicked in.

So, it appeared to be working but just not reflecting in the UI itself.

I ran the command

defaults write com.apple.screensaver askForPasswordDelay 0

to update the UI so it says “immediately”, reflecting the setting being applied by the profile. If I run the same command with

defaults write com.apple.screensaver askForPasswordDelay 600

The UI updates again - with the Profiles still in place - to show 5 minutes.

tl;dr - The Preferences -> Security UI is basing its timeout setting on the com.apple.screensaver askForPasswordDelay key.

jon_heyd
New Contributor II

I've attempted the iOS update push a couple of times without success. The logs on the iPads show the following (reversed from logs page into chronological order):

DeviceInformation Yesterday at 6:40 AM
Update Inventory Yesterday at 12:48 PM
AvailableOSUpdates Yesterday at 12:49 PM
ScheduleOSUpdate Yesterday at 12:49 PM
DeviceInformation Today at 6:40 A

iPad is still running 9.1

Little help here?

cdenesha
Valued Contributor II

The iPad received the command but the user probably cancelled the 10 second countdown with Later. They then may have said Remind Me Later. You can resend the command all you want but they won't get the prompt again. They will be prompted every 24 hours by iOS.