Catalina Update

hedenstam
New Contributor III

I am puzzled

I have a policy that deploys Install macOS Catalina.app to /Applications
I have a policy with a "oneliner" in Files and Processes: "/Applications/Install macOS Catalina.app/Contents/Resources/startosinstall" ‑‑agreetolicense

If I browse to the same location and run it manually in the Mac, I get "preparing to run macOS Installer" and I can see osinstallersetupd process in the Activity Monitor, so everything works fine manually.

Also I do not see the osinstallersetupd-process when I run the policy.

Any ideas what I am doing wrong?

9 REPLIES 9

carlo_anselmi
Contributor III

@hedenstam If I am not mistaken startosinstall requires a logged in user, how do you run the policy?
Cheers
Carlo

dennisnardi
New Contributor III

I think you may need an additional flag -nointeraction to make this automatic. Below is what I've used successfully.

/Applications/Install macOS Catalina.app/Contents/Resources/startosinstall --agreetolicense --nointeraction

Also @carlo.anselmi is correct and startosinstall requires a user be logged in to run.

hedenstam
New Contributor III

Yes 😃. Thanks a lot guys, I was able to get it work.

@carlo.anselmi The policy is available in the Self-service for users to start it from there.
@dennisnardi By adding the --nointeraction did the trick and now it works like it should.

Once again, thanks a lot 🙌

atrystan
New Contributor II

@carlo.anselmi You can use ARD to invoke it as root user, which is how we manage things. Essentially, copy the installer to /Applications then as root, run the startosinstall.

john_sherrod
Contributor II

I’ve been banging my head against the wall on this one. I’m also using a Files and Processes Self Service policy with the following command: /Applications/Install macOS Catalina.app/Contents/Resources/startosinstall --agreetolicense --nointeraction &

This has led to inconsistent results. Some of my test machines are installing flawlessly. Others just sit and never seem to do anything while still others will have an error to the effect that Self Service can’t save and quit, though if I click through the error dialogs it does quit, restart, and complete the install.

simon_brown
New Contributor III

@john.sherrod Haven't been able to get the startosinstall command to work properly at all. It starts preparing... but then crashes with system reboot failed. Tried different Macs but still the same.

uiqbaljamf
New Contributor II

I am in the same boat where I have deployed the Catalina installer package to targeted machines and set up a policy to execute the following command.

'/Applications/Install macOS Catalina.app/Contents/Resources/startosinstall' --eraseinstall --agreetolicense --forcequitapps --newvolumename 'Macintosh HD' --nointeraction &

02e29f9c811f4b0e9ddefdb81d27723c

In theory, this should quite all open apps, restart the computer, wipe the drive and install macOS Catalina.

All it does is create a new partition and dump the installer files in there. That's it !
What am I doing wrong here?

46882594811c4424a4821cb2aecbbe7c

My test machine is running macOS Mojave

anthonytji
New Contributor III

im having the same issue, i continue to get this error not matter what i do. 5a98df12e5284fb2bc215996bbba32e1

anthonytji
New Contributor III

Just found these steps and it WORKED, the only thing different i did was the command to erase the volume

diskutil apfs eraseVolume disk1s4 -name Vm 77b5f056d6194b55b47b7e0e6543fcc9