Composer Helper

jrippy
Contributor II

How can I stop Composer from asking to install the helper application every time it is opened? I'm running 10.26.1.
Even though I enter admin credentials, it never seems to be happy.
Is anyone else seeing this or is it just me?

14 REPLIES 14

sdamiano
Contributor

afaik this is expected behavior in composer.

jrippy
Contributor II

@sdamiano Just to clarify, it is expected that it will ask to install every time, even though I give it admin credentials to install and nothing has changed from the last time I opened it 2 minutes ago?

JustDeWon
Contributor III

@jrippy , it sounds like com.jamfsoftware.Composer.helper is not installed in /Library/PrivilegedHelperTools/.. You may want to navigate to validate.

If it's not installed, you can navigate to the Composer.app>Show Package Contents>/Library/LaunchServices/ and copy the com.jamfsoftware.Composer.helper and place it in that location(/Library/PrivilegedHelperTools/). Not sure why it's not staying there for you after your initial "update" when you 1st opened it

jrippy
Contributor II

@JustDeWon Thanks for the reply. That was my thought as well before I posted this thread. The problem is though, that is it there. That's why I was wondering if it was normal to continuously prompt me.
And for another data point, the computer I am currently on is a new install on a clean hard drive with Big Sur. This was happening previously on Catalina before the hard drive was wiped. Additionally, this happens on my laptop running Catalina as well.
So, it doesn't appear to be something specific to this computer from what I can tell. Hence the question, is this normal?
922154a3a2c54827b90bf83ff24734a3

JustDeWon
Contributor III

@jrippy It's not normal, but it seems corrupted maybe.. I would just delete it from there and replace it with the newer one within the app. See how that works out for you.

JustDeWon
Contributor III

@jrippy , Actually I stand corrected. It prompts me to install each time I open as well. And I'm on Jamf 10.27.0 and macOS Big Sur. This could possibly be a bug with Jamf. I don't recall having to do this each time previously. But I'm hardly in Composer

poormatt
New Contributor III

Been happening to me for many many versions now. I deal.

jrippy
Contributor II

@JustDeWon Thanks for verifying that. Glad to know I'm not crazy!
@poormatt Me too. I finally had a free moment though and searched the forums about it. Finding nothing, I decided to post this thread.
Like you, I assume most people just go with it.

emclean
New Contributor II

I am also having the problem on a Big Sur machine(fresh install of OS) running 10.27. I can't create packages, but can create DMG files just fine. It prompt to install the helper tool every time. I have uninstalled & reinstalled and it does not help. Has anyone found a fix for this?

jorice
New Contributor II

Tail var/log/system.log (tail -f /var/log/system.log) while opening Composer. if you see this in your entry "ownership/permissions path" check the posix permissions on the file com.jamfsoftware.Composer.helper.plist in /Library/LaunchDaemons/ to make sure they are set to 644 and root:wheel. Jamf did not set these correctly on the first install. Could be a misstep in their composer package ironically. This worked for me. Reopen Composer and you should be good to go. Cheers!

disregard my chmod command that I fat fingered d011c94ced1842389bb5b5683b50290a

jorice
New Contributor II

Jun 30 13:58:59 tsdev31b com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.system): Caller specified a plist with bad ownership/permissions: path = /Library/LaunchDaemons/com.jamfsoftware.Composer.helper.plist, caller = smd.221
^C
tsdev31b:Jamf Pro root# cd /Library/LaunchDaemons/
tsdev31b:LaunchDaemons root# ls
com.adobe.ARMDC.Communicator.plist com.attotech.attotlnclogd.plist com.microsoft.OneDriveUpdaterDaemon.plist com.splunk.plist
com.adobe.ARMDC.SMJobBlessHelper.plist com.ipv.PluginHelper.plist com.microsoft.autoupdate.helper.plist com.wacom.UpdateHelper.plist
com.adobe.acc.installer.v2.plist com.jamf.management.daemon.plist com.microsoft.office.licensingV2.helper.plist com.wacom.displayhelper.plist
com.adobe.agsservice.plist com.jamfsoftware.Composer.helper.plist com.microsoft.teams.TeamsUpdaterDaemon.plist io.projective.pamFS.Mounter.Helper.plist
com.aja.cmio.ajaassistant.plist com.jamfsoftware.jamf.daemon.plist com.oracle.java.Helper-Tool.plist org.wireshark.ChmodBPF.plist
com.apple.installer.osmessagetracing.plist com.jamfsoftware.startupItem.plist com.pam.client.continuumtransfunctionerhelper.plist
com.attotech.attocfgd.plist com.jamfsoftware.task.1.plist com.promise.sanlinkdaemon.plist
com.attotech.attotlfc16logd.plist com.microsoft.OneDriveStandaloneUpdaterDaemon.plist com.redgiant.service.plist
tsdev31b:LaunchDaemons root# ls -las
total 224
0 drwxr-xr-x 31 root wheel 992 Jun 30 13:43 .
0 drwxr-xr-x+ 68 root wheel 2176 Apr 1 11:47 ..
8 -rw-r--r-- 1 root wheel 474 Jan 9 02:44 com.adobe.ARMDC.Communicator.plist
8 -rw-r--r-- 1 root wheel 486 Jan 9 02:44 com.adobe.ARMDC.SMJobBlessHelper.plist
8 -rw-r--r-- 1 root wheel 564 Apr 1 11:05 com.adobe.acc.installer.v2.plist
8 -rw-r--r-- 1 root wheel 642 Apr 1 11:05 com.adobe.agsservice.plist
8 -rw-r--r-- 1 root wheel 533 Jul 26 2019 com.aja.cmio.ajaassistant.plist
8 -rw-r--r-- 1 root wheel 632 Apr 12 01:43 com.apple.installer.osmessagetracing.plist
8 -rw-r--r-- 1 root wheel 706 Mar 21 2019 com.attotech.attocfgd.plist
8 -rw-r--r-- 1 root wheel 706 Jun 13 2019 com.attotech.attotlfc16logd.plist
8 -rw-r--r-- 1 root wheel 698 Nov 28 2017 com.attotech.attotlnclogd.plist
8 -rw-r--r-- 1 root wheel 881 Feb 26 2020 com.ipv.PluginHelper.plist
8 -rw-r--r-- 1 root wheel 764 Feb 4 10:02 com.jamf.management.daemon.plist
8 -rw-rw-r-- 1 root wheel 588 Jun 30 13:58 com.jamfsoftware.Composer.helper.plist
8 -rw-r--r-- 1 root wheel 710 Apr 26 14:36 com.jamfsoftware.jamf.daemon.plist
8 -rwxr--r-- 1 root wheel 474 Apr 26 14:36 com.jamfsoftware.startupItem.plist
8 -rw-r--r-- 1 root admin 537 Apr 26 14:36 com.jamfsoftware.task.1.plist
8 -rw-r--r-- 1 root wheel 793 Apr 1 11:29 com.microsoft.OneDriveStandaloneUpdaterDaemon.plist
8 -rw-r--r-- 1 root wheel 537 Apr 1 11:29 com.microsoft.OneDriveUpdaterDaemon.plist
8 -rw-r--r-- 1 root wheel 428 Jun 22 13:29 com.microsoft.autoupdate.helper.plist
8 -rw-r--r-- 1 root wheel 657 Sep 8 2019 com.microsoft.office.licensingV2.helper.plist
8 -rw------- 1 root wheel 271 Apr 1 11:29 com.microsoft.teams.TeamsUpdaterDaemon.plist
0 lrwxr-xr-x 1 root wheel 103 Apr 1 11:33 com.oracle.java.Helper-Tool.plist -> /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Resources/com.oracle.java.Helper-Tool.plist
8 -rw-rw-r-- 1 root wheel 1164 Jun 22 13:52 com.pam.client.continuumtransfunctionerhelper.plist
8 -rw-r--r-- 1 root wheel 633 Sep 14 2017 com.promise.sanlinkdaemon.plist
8 -rw-r--r-- 1 root wheel 922 Oct 1 2019 com.redgiant.service.plist
8 -rw------- 1 root wheel 507 Apr 1 11:39 com.splunk.plist
8 -rw-r--r-- 1 root wheel 1126 Mar 19 2019 com.wacom.UpdateHelper.plist
8 -rw-r--r-- 1 root wheel 813 Mar 19 2019 com.wacom.displayhelper.plist
8 -rw-rw-r-- 1 root wheel 859 Jun 22 13:42 io.projective.pamFS.Mounter.Helper.plist
8 -rw-r--r-- 1 root wheel 382 Apr 1 11:43 org.wireshark.ChmodBPF.plist
tsdev31b:LaunchDaemons root# chomd 644 com.jamfsoftware.Composer.helper.plist -sh: chomd: command not found
tsdev31b:LaunchDaemons root# chmod 644 com.jamfsoftware.Composer.helper.plist tsdev31b:LaunchDaemons root# tail -f /var/log/system.log

jrippy
Contributor II

@jorice - Thanks for the reply but that is unfortunately not my issue.

My permissions are correct (644 and root:wheel), but I see this in the system.log on launch:
"

Aug 19 16:06:31 CLEM311-D01N com.apple.xpc.launchd[1]: Coalition Cache Hit: app<application.com.jamfsoftware.Composer.2477569.2477578(2004433752)> [304787]"

 

And it still prompts me every single time I open Composer.  Frustrated of this behavior.

Aug 19 16:06:31 CLEM311-D01N com.apple.xpc.launchd[1]: Coalition Cache Hit: app<application.com.jamfsoftware.Composer.2477569.2477578(2004433752)> [304787]"

 

And it st

araney
New Contributor II

I have the exact same behavior on like 3 machines in a row.

jrippy
Contributor II

@araney Yep, it has never gone away for me either.  Seems like Jamf isn't interested in fixing it.