Configuration Profile to "Enable Screen Recording" no longer functions correctly under Monterey

Mudnight
New Contributor
We have found that on Monterey devices, using a previously working (as in worked on Big Sur) configuration profile to enable screen recording for Google Chrome, Slack, and Zoom no longer works correctly. To explain, the config places the three under Screen Recording in the privacy menu, allowing the standard user to checkmark them. For the profiles, we tried both enabling and disabling "Big Sur compatibility".
 
Now when attempting to share the screen, the applications still prompt for the user to checkmark the options, even though they are already check marked. 
 
When we manually add the three applications through Privacy, they function normally. 
 
Has anyone else run into this? 
 
I've included the PPPC for Zoom, as an example

 

Identifier: us.zoom.xos
Identifier Type: Bundle ID
Code Requirement:
identifier "us.zoom.xos" and anchor apple generic and certificate 1[field.1.2.840.113635.100.6.2.6] /* exists */ and certificate leaf[field.1.2.840.113635.100.6.1.13] /* exists */ and certificate leaf[subject.OU] = BJ4HAAB9B3

App or Service          Access
ScreenCapture           Allow Standard Users to Allow Access

 

3 REPLIES 3

bcrockett
Contributor

Yes for chrome I think this is related to this bug.  Still looking for an easy solution. 

Rohit1
New Contributor

Hi, Can you Please explain how to add manually the three applications through Privacy

Below is a screen shot of the config profile I am using for Zoom. 

 

Screen Shot 2022-09-13 at 7.42.10 AM.png