creating Adobe CC installs with Composer

New Contributor II

Does anyone have a way to create Adobe CC installers with Composer?


Valued Contributor

It's not possible with just Composer. You'll need to create an installation package with the Creative Cloud Packager (CCP).

For more information, see the following links. There are also plenty of discussions on JAMF Nation. CCP is very similar to AAMEE (which was used for CS6), so there might be some information in those threads that can help you out as well.

CCP Documentation:
Deploying PKGs Created with AAMEE or Creative Cloud Packager:

New Contributor III

Msblake is correct you need to use the Creative Cloud packaging tool to create packages for Adobe CC. The good news is that these can be installed as .pkg and no longer need to be wrapped in a .dmg.

We have had a lot of success with the CC packager and only experienced issues when any Adobe Applications are open during the install or if the permissions are off. We also verify the sleep settings before deploying the entire CS to ensure that it finishes properly.

We did have one very weird issue where InCopy was unable to install when deployed via Remote but opening the .pkg and manually installing was successful.

New Contributor II

well the main problem I am having is that the actual adobe packager, the end product .pkg when I try to install on mavericks it craps out. so I was trying to find a way to repackage those files.

New Contributor III

I would start by looking at the log files. Here are several locations that they can be found:

1) /private/var/log/install.log
2) /tmp/oobelib.log
3) /tmp/amt3.log
4) ~/Library/Logs/PDApp.log
(Ignore those not present on the system)
Adobe is pretty good about giving a vague error code but if you Google the error you should find several forum postings or KB articles through Adobe to help you.

This helped me determine that several of our issues were permission or conflicting process based.

Also here is a link to the Adobe Enterprise forum:

You may be able to post your error logs there and receive help.

Hope that information helps!

If you would like to post a more detailed description of the issue or some logs people are more than happy to take a look, here or on Adobe’s forum. The nice thing is on Adobe forums the Adobe moderators sometimes provide solutions.

Valued Contributor

The first thing I would try is double clicking the installer to run it manually and see if it completes. If not, it is likely to either be a permission issue within the CCP created PKG, or it is being corrupted when placed on your distribution point.

Valued Contributor

We had a helluva time with CCP created packages when we first made them. The installers would fail each time.

To solve this we did 2 things...
1. Remove any spaces in the package name
2. Did a chmod -R 755 on the entire package.

Since then installs have been good to go.

New Contributor III

Just to confirm with Caitlin if I am reading this correctly:

"The good news is that these can be installed as .pkg and no longer need to be wrapped in a .dmg."

Does this mean that after I have created my CC .pkg I can add it to the imaging workflow ? Because when I tried this, it was just ignored and nothing was installed. However if I just double click the installer it all installs with no problems at all.

I was looking at this link :

And it looked like I would need to copy the .pkg inside a DMG and deploy it using a policy.

New Contributor III

No, if you are attempting to install the Adobe packages at imaging they will not work (to my knowledge). We have to have policies kick off the Adobe installs after imaging. We use a receipt (com.needs.adobeCS6.dmg, for example) in the /Library/Application Support/JAMF/Receipts/ and an extension attribute to flag the machine as "needing" these packages. We then deploy a script via policy to trigger the cache and install of the packages.

Sorry, I must have missed that this was at imaging you were experiencing issues. While the process of deploying Adobe packages has improved it still is not complete because it does not work at imaging.

Let me know if you have any other questions or if you would like me to provide more detail.

Contributor II

Yes, Caitlin

This is exactly the issue I am seeing.

- Using the latest CCP 1.4, and created pkgs for all 12 Adobe CC apps
- When uploading these pks to Casper Admin, CA adds the .zip extension, apparently as it's supposed to
- These Adobe pkg. zip files Do Not install at Casp Imaging time, they get skipped over. Unless you check, Install on boot drive after Imaging, which as you know is copying the Adobe pkg installer to the drive, and then at the dreaded "black curtain", installs. This is just slow and dreadful. Somehow there has to be a fix / better way.

- Taking these Adobe CCP pkgs and using Composer (taking a snapshot), essentially repackaging, and uploading to Casper Admin, works. But...

When you go to open the Adobe app, you get the "Adobe Update Manager is missing or damaged"

- Have been doing the Adobe CC installs with Self Service, and for the most part that works, but if you "Queue" them up, only the first Adobe CC app gets installed, and you might get the dreaded, "Self Service is unavailable". I would say this should be one the top priorities at JAMF, getting this working with Adobe.

- What would be a better and faster workflow for getting the Adobe apps installed quickly? I can think of taking the base OS 10.9x image and placing the basic Adobe apps along with it. Photoshop, InDesign, Illustrator, Acrobat. This might result in a faster, more efficient Casper Imaging process, but defeats the whole purpose of "modular" imaging, with Casper Imaging.

Really the Adobe CC apps should just come down at Casper Imaging, like any other app / pkg.

Your update / feedback much appreciated.



Valued Contributor

"Really the Adobe CC apps should just come down at Casper Imaging, like any other app / pkg."

But they are not authored in such a way to make this possible. This is not a JAMF issue, it's an issue with packages created by AAMEE and CCP.

You must install AAMEE and CCP packages to the currently booted OS volume, which precludes doing it as part of an image.

Contributor III

gregneagle is right - Adobe has always been a "special" category with the JSS. (Notice the "New Adobe Install" button in CA.) It doesn't help that Adobe is constantly changing the way their stuff deploys, either.

Contributor II

thx guys, understood.

As well as my apologies to JAMF, and forgive me of my ignorance on this.

So is the general practice (these days), to have the Adobe CC apps, at Casper Imaging time, to check box, "Install on boot drive after imaging", or something else?

Of course the Self Service install does work. But, there can be issues with that (Self Service unavailable message), but that is another story.... (have to unenroll and re-enroll, as a workaround).



Esteemed Contributor III

@Caitlin_M wrote:

We then deploy a script via policy to trigger the cache and install of the packages.



New Contributor III

We are still having this problem. I am using the Adobe forums, which can be seen at the following link -

I have used every method I know of to deploy CC through Casper Suite, but nothing is working. I cannot even cache the .pkg and install locally. I've also tried the method, but it always fails at the install. I have re-packaged the applications from scratch and done chmod -R 755 on the packages.

The Adobe Forums link above includes my most recent error log. Thank you for your help. I'm getting a little concerned as I approach imaging season here at the university.