Database Backup with Jamf-Pro CLI issue

New Contributor III


I recently tried to create a database backup with the newly integrated command line interface as described here:

After configuring the settings I execute the command "jamf-pro database backup", then I have to enter the config file encryption key and the backup starts and holds nearly instantly at "Compressing..".
There it stands still for hours at 0.00 MB.

Our system: Cent OS 6.4
JSS 10.7.1

Anyone experienced this behavior?

BR Thomas


Valued Contributor

Seeing same behavior. It's just stuck at compressing. Before that, it showed tens of hours to do the backup, then went to compressing.

Me thinks something's not quite ready with the jamf-pro binary. =/

I'm on RHEL7.5

New Contributor II

I found the same problem when running the backup using the mysql credentials of the JAMF user, switched it to using the root credentials for mysql and it runs through without issue.

New Contributor III

Found the issue on our side:
I have downloaded and installed the CLI as described here.
Apparently that confused the server since the CLI is preinstalled in JSS 10.7.1 too, so I removed it with "yum remove jamf-pro-server-tools".
Used the root user instead of the mysql jamf user (as suggested by symbolic78) and finally it worked.
BR Thomas

Contributor II

Hello @rstasel, the issue with the backup getting stuck on compressing should be fixed in v1.1.3 of the tool which has already been published. See Using the Jamf Pro Server Tools Command-Line Interface
to download the latest version since they are newer than was was included with 10.7 or 10.8 beta 1 and 2.

There are also some additional issues with running it on RHEL, and the team is currently working on a fix that will be included in the next release which should address the issue @symbolic78 pointed out.

@thomas.moser Excellent point, we should update our KB to let folks know to use one of the two methods for obtaining the tool or to replace the existing one if running it on the same server where Jamf Pro was installed.