Device compliance Error

New Contributor


I am having trouble setting up device compliance in Jamf Pro. I followed the instructions found here: but when I got to the part where I was redirected to the Microsoft Intune webpage, nothing happened. The Microsoft login window appears; I enter my email address and am then brought back to Jamf Pro with a "Registration Request" error and another warning below that states it is "Establishing connection" with directions to "Open consent URL." I click on the open consent URL, get to the Microsft login window, enter my Azure email address, and am then brought back to the Jamf Pro screen with these same two messages. 

I have Azure GA rights and have tried two different browsers (Safari and Edge) with no success. Has anyone else come across this issue? I figured that I'd try here before submitting a ticket with Jamf. 


Here is the error and warning messages


Registration request error
Jamf Pro cannot connect to Microsoft Intune. Click the “Open consent URL” button below to grant permissions requested by the Azure application in Microsoft.
Establishing connection
The connection with Microsoft Intune is currently being established. If you have not consented to the permissions requested by the Jamf Azure application in Microsoft, you must do so now

New Contributor


from which device did you tried to grant the permissions? Please try from a already Intune/Entra registered device, where no compliance rules will stop the process. I saw in other environments that the process was skipped, caused by compliance rules.