Disable Netbios on OS X 10.11-10.12

skinford
Contributor III

Good morning everyone!,

I have gone through the messages here and also most places on the web. I have tried most scripts such as:
sudo launchctl disable system/netbiosd, and while that runs it does not seem to disable netbios, I still see everything in the Finder side panel even after running the script just mentioned.

I need to find a solution according to our security team and while we were able to do this on our OS 10.10 systems which was before I got involved with the Macs, by renaming the netbiosd file. I cannot seem to grasp the fix to diable netbios on newer Macs.

And why is it even activated on a new system with a standard Bind to AD? Where does it get connected? Is it being pushed by our AD? I don't even see those settings in the Bind section of Directory Utility.

I am curious how anyone else is doing this. I have to get this addressed shortly.

Have a great day everyone, I appreciate all of you!

2 REPLIES 2

donmontalvo
Esteemed Contributor II

Why not set up a firewall rule to block port 137-139? Take a look at the Krypted article.

--
https://donmontalvo.com

skinford
Contributor III

Thank you @donmontalvo !

Got backed up and are trying this right now.

Have a very great day today!