Distribution points - adding from Casper Admin results in "error 413"

New Contributor

I'm currently setting up a fresh JSS instance and file distribution points. Now, I seem to have hit a brick wall: It appears that no file distribution method I've tried allows me to upload files using Casper Admin, and they all fail with a very similar error

Anytime I drag a .pkg (built with Casper Composer) into Admin's Package list, it shows me a progress bar for the upload, and at around 97% displays this message:

There was a problem uploading the package to Amazon Web Services. The operation couldn't be completed. ( error 413.)

(This is for a master cloud distribution point using an S3 bucket to which the user has full access; the "Test" button in JSS says "The cloud service was successfully contacted."). I have tried setting up a JDS server as the master dist point on a Mac Mini on my LAN, and that resulted in almost the exact same error message (except with JDS substituted for AWS). The S3 bucket doesn't contain the file when that error occurs, and neither does the JDS.

All the logs I could find on the JSS server don't mention any problems, and I can't find any documentation on a (n at a guess HTTP) error 413 at AWS.

What can I do to debug this or, ideally, fix it? I'm pretty much completely stuck at the moment.

Thanks for any & all help,


New Contributor

@asf-stripe Have you solved this issue. I am experiencing this now.


New Contributor

We managed to no longer run into this issue! Mostly by not uploading through Admin, but through the JSS webface (this is a hint I got during jumpstart, and it's been working reliably).

However, I revamped this setup a bunch of times in the year since I posted this (finally got everything working - including uploads from Admin - in a satisfying way in September 2014). The thing that made file uploads to JSS work for us was the fix I detailed in https://jamfnation.jamfsoftware.com/featureRequest.html?id=2034#responseChild7128: eliminating the nginx proxy between our JSS and clients. This may not be the thing that makes it work for you, though ):

Best of luck!