DO NOT install 9.7 if you use http distribution points.

Contributor III

And have packages with spaces or special characters in the name. Package deployment will not work. I can't believe they are even still providing it for download. We wasted hours on this.

From support:
"Likely the reason you all are having issues with HTTP on 9.7, is defect: D-008880

Unfortunately, packages with spaces or special characters in the name will fail. We've also seen issues if the HTTP share name has a space or special character in the name. "


Valued Contributor II

There is a thread on here discussing this issue.

I would have just shortened the thread title to: "Do Not Install 9.7"

Have advised my clients not to upgrade due to this, and other, defects...

New Contributor III

@Dickson It will work... read on for the workaround

@RobertHammen You could install it - but you will have a lot of pain.

The behavior of the LIKE Operator changed. A percentage-character(%) now is a real character, means that if you build a Computer Group with this Criteria "ComputerName LIKE iMAC-%" and want to address Computers called iMAC-12354 this will fail.
Workaround: Remove the percentage sign. If you have plenty of groups (>350 in my case) you may not waste two hours and modify it with proper sql statements. Make a Backup of the Database BEFORE.
You will have to do this anyway, the support told me, since this is the "new" wanted behavior :)

(Active)Directory Binding will fail if your Bind-User has a Password which contains some specialcharacters.
Workaround: Remove the Characters, wait for an update containing the fix.
CasperRemote will fail if your Management-User has a Password which contains some specialcharacters.
Workaround: Remove the Characters, wait for an update containing the fix. One specialcharacter is said to be fixed within 9.7 - read the "Fixed Bugs section".

Client could not download from the Distribution Point Pkg.dmg
Workaround: remove all spaces within the PKG and DMG Names. Update the names within JSS. Do NOT start Casper Admin while doing that. How you could have seen it... within previous releases the error mail contained a fully functional link, this release sends a malfunctional link.

About all other errors within the forum.... just dont update your netboot image and stay with your old one :)
I'm still running on 10.10.0 with CasperImaging 9.6

Best regards,

New Contributor

I was having the same trouble getting policies to run (Google Chrome, Adobe Flash), deleting the spaces in the DMGs in Casper Admin worked for me.



hi guys is this problem with cloud version of Casper suite to.

Kunal V

New Contributor II

The Problem is sorta fixed in 9.71 but with a new bug: with Version 9.71 the URL for the package download URL is completely broken. The path-part of the URL consists of the (correct) package path followed by the same path again: Suite.dmg/Packages/Casper Suite.dmg

In the past JAMF reacted promptly and fixed bugs really fast. I am a little bit angry at the fact how long this (IMHO) show-stopper bug ist open this long (actually four weeks).

I hope JAMF will fix this soon!

Best regards,


Esteemed Contributor III

@bofh wrote:

Workaround: remove all spaces within the PKG and DMG Names

We've always avoided spaces and illegal characters. If we find a package that was uploaded with spaces, we rename it from within Casper Admin. Editing stuff directly off the DP is probably not a good idea.


New Contributor III

@donmontalvo Well if you rename it equally within the Webinterface it should be no Problem. I have to say, that we just have one HTTP(s) DP which is the JSS Server itself.
I tried to avoid them too, but some pkgs created by any autopkgr recipes will contain spaces.
Aswell as bad named "Composer" PKGs and DMGs.
But really... a Bug about spaces in filenames in 2015? Really? Really?
Anyway it's said to be fixed in 9.71 - gotta ask my Boss if I can upgrade to it, since it comes with a lot of Known Issues aswell.

Esteemed Contributor III

@bofh I'm there with you, it's just that by never using spaces or illegal characters it puts you in the safest position. Bugs happen (in any platform/application) and that's one I prefer not to be bitten by this one. Plus it avoids URLs with "%20", makes terminal commands easier, etc. but yea I hope it's fixed in 9.71 too. :)


Release Candidate Programs Tester

This issue does not appear to be fixed in my testing last night:

Install Latest Adobe Flash Player.pkg = failed installation
Install_Latest_Adobe_Flash_Player.pkg = successful installation.

Both packages used in the testing were otherwise identical. The only difference was the naming.

For more info, please see this thread:

Release Candidate Programs Tester

A feature request was put in a while ago to implement a bug reporting and tracking system on JAMF Nation, which would hopefully make it easier to find and squash bugs like this before they make it into releases of Casper. If nothing else, the Nation offers a wider testing pool than JAMF could possibly assemble internally.

If you haven't already voted for this, please hit the link below and vote it up!

New Contributor III

@donmontalvo Yes sure, i tried to avoid that too, but all of the failed mails i got so fare came from autopkg(r) created pkgs.
so I patched them and will watch out if it happens again. Gotta push the recipes aswell - next week.

@rtrouton it's one of the most supported features, already voted it up ;)

Honored Contributor II
Honored Contributor II

@rtrouton yep, already voted up, I see its under review so fingers crossed that will get implemented.

@donmontalvo I'm with you! I know its 2015 and it should all work, but I don't like to put myself in the firing line so keep to shorter file names, no spaces (or any other characters that might cause issues).

New Contributor II

The http/https bug is fixed in 9.72