Enable Remote Control to Big Sur

Networld
New Contributor

Hi,

I try to enable Remote Control for Big Sur with a script. I try that :

 

/System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -configure -access -on -allowAccessFor -specifiedUsers
/System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -configure -users admin -privs -DeleteFiles -ControlObserve -TextMessages -OpenQuitApps -RestartShutDown -SendFiles -ChangeSettings
/System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -restart -agent -menu
/System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate

 

With Apple Remote Desktop I have a black screen. I run this command :

tccutil reset ScreenCapture

 

No more black screen. But, I can observe, but not control! πŸ˜…

3 REPLIES 3

J_Mukite
New Contributor III

You can not enable this via a script with Big Sur. It has to be an MDM command. For a quick fix, go into Jamf Pro / Management Commands / Disable Remote Desktop and then enable it again. This will keep all the settings from your script in place and will actually allow you to remote the device. At least that works for me. Hope that helps. 

swhps
Contributor III

How do you automate that?  We have to toggle that setting for each machine? 

J_Mukite
New Contributor III

I only do this on an as needed bases, not every machine. It only takes a few seconds and I don't mind it. I don't believe you can do this in mass in the Jamf Pro UI. You might be able to do with with the Jamf Pro API. I'll see what I can find out.