Enrollment Invitations - Nothing gets downloaded to user's computer

New Contributor III

We have recently come upon an issue where a user is trying to enroll via enrollment link (or even by manually logging in by going to yoursite.jamfcloud.com/enroll) and no files get downloaded to install the certificate or configuration profiles. The browser just sits there thinking it downloaded the certificate, but it just waits for the user, as if it were waiting for them to accept the installation from the system preferences.

Not sure why this isn't working, as it seems to be affecting macs that are trying to enroll from about a week or two ago.

The current workaround seems to be using a different computer the link does work on, then download the files using firefox (may be an old version), and copy the files to the new computer to install manually. Everything installs like normal after that. Any browser used on that particular machine cannot be used to enroll the system itself, as no files will actually download.

Anyone experience something similar?


Valued Contributor

in terminal: sudo jamf checkjssconnection

then, try: sudo jamf enroll -prompt
sudo jamf trustjss
sudo jamf enroll -prompt

New Contributor III

Hi @larry_barrett

This won't work because Jamf is not installed yet.

This would be an existing system that cannot be wiped out for DEP to do its magic.

We would need something to facilitate the downloading/installing Jamf based on our enrollment invitation, etc.

New Contributor

I had this same thing happen on one of our older machines that is not in DEP using the URL. It seemed to just hang in Safari on a newly wiped Mojave OS. I got it to work after I rebooted - it then downloaded the mobileconfig.

Contributor III

In case anyone else runs into this:

I started having a similar issue on a system I'm testing on doing pre-stage without dep. 10.15.7. Enrolled and everything went fine. ran "jamf -removeFramework". Rebooted, removed computer from jss, restart jss. Upon pre-stage enroll via URL/enroll, it thinks it downloads the mobileconfig files, I even see them blink in the downloads folder briefly, but safari reports they failed to download and no files are left on the disk. Clearing safari cache and history did not help, nor did any of the various restarts of components. Tried enrollment via firefox esr, current version, and files downloaded fine/enrollment worked. So it seems in my case to be something with safari. I probably could have worked around it by trying under a different user profile or brute force removing safari profile data.