Enrollment Stalls - No JAMF Binaries - Listed as Serial Num and Not Machine Name

New Contributor III

I've been trying to enroll this iMac for three days without success. Everything else on our campus enrolls just fine.

iMac 12,1
High Sierra 10.13.6

I can install both profiles/certificates but then the process just craps out. It never progresses. If I search JAMF for the name of the computer, I get no result but it does create a machine in JAMF using the serial number of the machine instead of its name. The rest of the data is JAMF is pretty sparse. UUID and some other data but nothing else gets populated. The machine never receives the JAMF binaries and there is no other movement.

This is a JAMFCloud install so I can't really look at server logs.

Anyone else run into this before?


Contributor III

Have you wiped the machine or tried deleting the computer record in Jamf Pro between enroll attempts?
What happens if you use a package made with Jamf Recon? That should essentially force the agent onto the machine.

New Contributor III

@jmcmahon1 You can try deleting the computer record from JSS and then try to enroll using a enrollment invitation url or quickadd package.

New Contributor III

I've tried all of these things. The machine reports an incorrect serial number, WAAAAY to long to be a valid number. I was on the phone with Apple for an hour and they remote viewed the machine and were baffled. I have a case open with Apple.