Error adding Printer in JSS

Not applicable


Long time listener, first time caller...

We just did a major software upgrade/machine rebuild to a number of
workstations last week. Overall the process was smooth as silk thanks to
the Casper suite. One issue that is still lingering has to do with the
addition of a Xerox Phaser 7760 color printer. When adding it to the JSS,
we get a Casper Admin error, followed by a SQL exception. This error only
occurs with this specific printer.

In OSX, the printer is added via IP as a Generic Postscript Printer first,
then the driver is associated manually. The connection type is a socket://
connecting to a Xerox Phaser 7760DX. Our JSS is version 8.0.

Has anyone seen this before and know why this is happening? Any assistance
would be greatly appreciated.


-- -- -- -- -- -- -- -- -- --
Dave Simon
Director, Media Engineering and Operations

T +1.415.808.3594 | F +1.415.808.3535 | C +1.617.908.5043
600 Harrison St € San Francisco, CA € 94107

PRN | media where & when it matters

![external image link](attachments/0862e878be494f5e8049e7d23a440a3f)


New Contributor

I have seen this in version 7.3 or 7.3.1 I forget. I have not tried since and we are on 8.1 now. I believe we ended up picking another similar printer model and it worked.


New Contributor

I am having this same issue with our Phaser 7760. The error points out that the packet value is too large, though, I'm not sure where I should go to change the value. I'm running Casper 8.43, and am pulling the printer off an OS 10.7.3 client.

external image link

New Contributor III

Has anybody found a fix for getting this printer installed?

Valued Contributor II

I'm in the process of a deployment of OS X 10.8 and the only way i've found to cleanly add the Xerox phasers is manually using their printer driver installer. During the installer, it performs the set up of the Phaser. I don't see any way around not using the driver installer. Thoughts?

New Contributor II
New Contributor II

@pregash The error you are seeing is due to the size of the printer PPD being larger than the Max Packet Size set in MySQL. To fix this, we will need to increase the Max Packet Size from the default 1 MB. This can be done in the JSSDatabaseUtil.jar located in /path/to/JSS/bin on the JSS server.