Exception: Exception during pool initialization



Anyone ever experience this?


Valued Contributor II

Silly q, but have you verified the connection's happy, tap the edit connection and see if all fields are filled in.

New Contributor

Restarted our Mac server and now currently the same error message.
Were you able to resolve to resolve this?

New Contributor

Ummm... I have the same problem...

New Contributor III

I was running some VMs tonight trying to create a Linux JSS and having another Linux JSS to connect to the main's mySQL database and I ran into this issue. Replicated it twice.

When I used the secondary Linux JSS (without mySQL) to attached to the Windows JSS (with mySQL) it works perfectly fine.

I know it doesn't help but maybe someone can make sense of this?

New Contributor III

I upgraded our OS X Server from 10.9.5 to 10.11.5 and ran into this issue. Someone please help.

Update: Looks like MySQL was stopped on the first boot after the upgrade. As soon as I started MySQL, the JSS started.

New Contributor III


I had the same exact problem.

I think this is caused by the JSS installer assuming your MYSQL credentials are;

REF: JAMF Software Server Installation and Configuration Guide for OS X

The default MySQL settings used in the instructions below are:

Database name: jamfsoftware
Username: jamfsoftware
Password: jamfsw03

So when updating your JSS it applies Password: jamfsw03 to connect to your MySQL.
If you did not use the default password when your JSS was first setup,
then you get the error message @kenergy mentions.
Click the edit connection button and put in your MySQL DB password.
This resolved the issue for me to get JSS up and running.

Now this problem will occur each time Apache Tomcat restarts. This is due to Database.xml located under "/path/JSS/Tomcat/webapps/ROOT/WEB-INF/'. Under file line 9 <DataBasePassword>jamfsw03</DataBasePassword>.

Looks like the Maintenance version sets this to default during installation.
Change the password,save the file and restart tomcat. Your JSS will boot normally.