FileVault Logs

New Contributor III

I have a small handful of computers that are failing to enable FileVault. They have deferred enablement turned on and when the user logs in they are prompted to enable FileVault but when they click "Enable" it simply logs them into their account without enabling FileVault. I have tried disabling FileVault then running the policy again and have tried it with different users but we always seem to end up in the same loop.

I have tried searching the Console for errors to no avail and can't seem to locate anything helpful.

Does anywhere know where I might find some logs to help explain why this is failing?

Affected machines are running 10.12.6.



Not sure on logs but have seen a few situations that have had to complete the below steps to "reset" FileVault on systems. Also make sure the systems have a Recovery Partition as I believe this will prevent FV from enabling if missing

-System asking to Enable encryption while machine is not in a policy to receive it Delete - /Library/Preferences/

-From terminal sudo fdesetup disable (then reboot to "reset" any deferments)

Not sure if any of this will help with your situation

New Contributor III

Thanks for the suggestions! Unfortunately, they didn't do the trick this time.

I have had success using these steps with several of the other problematic computers but there's still a few that are stuck.

Any other ideas and does anyone know where there might be a log with useful information?