Has anyone managed to package TextExpander 5.0?

New Contributor III

It appears that TextExpander 5.0 has a new licensing format which does not work with the method mentioned here: https://jamfnation.jamfsoftware.com/discussion.html?id=8069.

There's now an additional .license file installed in these two locations:
- /Users/Shared/TextExpander/.license
- /Library/Application Support/TextExpander/.license

I tried replacing these along with the plist mentioned in the other discussion but the software doesn't recognize the new data. It simply erases the information and reverts the files back to the unregistered state. I also tried running defaults read on the whole plist after I copied it just in case it was a caching issue but that doesn't help.

Anyone have any luck getting the new version deployed?


New Contributor III

New Contributor II


I am also trying to get this done. Did you have any luck?

Thanks for any info!


New Contributor III

No luck yet. We've emailed the developer to see if they have any suggestions.

New Contributor III

New Contributor

I have been following that article but running into errors, have you guys had success?

New Contributor

Here's the postinstall script I wrote to solve the problem:

#! /bin/bash

for i in `dscl . list /Users | grep -v ^_.* | grep -Ev 'daemon|macports|nobody|root|Guest'` ; 
do sudo -u $i sh -c '
     defaults write com.smileonmymac.textexpander ActivationCode "[YOUR LICENSE KEY HERE]"
     defaults write com.smileonmymac.textexpander ActivationName "[YOUR LICENSE NAME HERE]"
     defaults write com.smileonmymac.textexpander ActivationEmail "[YOUR E-MAIL HERE]"

It's sort of overkill, but this will run the defaults write commands as every user on the system EXCEPT the service accounts listed in the two grep statements. If you just want to install it within the context of the users on the box. I haven't actually built a policy to deploy this yet, but the package finally works.

You might be able to get away with a sudo -u $USER instead of the whole loop thing if you were only interested in the active user, but I suspect that might actually run in the context of the service account. I'm not totally sure, I'm very new to Casper (finished our Jumpstart TODAY) and I come from a Windows background.

NOW if I could just get the pesky SUBSCRIBE TO OUR MAILING LIST prompt to bug off...