Hiding FileVault in setup assistant - greyed out

aandino
New Contributor III

I'm trying to hide FileVault option from being offered in setup assistant during pre-stage, and when I go to customize what steps I want to show, it's greyed out and I cannot skip it. Currently testing on a Mojave machine, but we also are deploying Ventura machines. Looking at Jamf and Apple documentation it seems I should be able to block this, but I can't figure out why its not allowing me to.

 

1 ACCEPTED SOLUTION

Bol
Valued Contributor

Do you configure the 'Account Settings' payload, if so that is by design. 

Bol_1-1687529814373.png

Bol_0-1687529705012.png

Bol_2-1687529870227.png

 

 

View solution in original post

5 REPLIES 5

Bol
Valued Contributor

Do you configure the 'Account Settings' payload, if so that is by design. 

Bol_1-1687529814373.png

Bol_0-1687529705012.png

Bol_2-1687529870227.png

 

 

aandino
New Contributor III

Yes, I do have that configured, but I see that message there explains why I can't tick the box. The only thing I have set up is pre-filling the user info from the SSO sign-in. I don't quite understand why that specifically would prevent FileVault from being disabled.

Bol
Valued Contributor

So it's a little back to front in whats written (will disable in Setup Assistant) where items you want disabled are ticked. Jamf is actually disabling the check box as empty when I guess it should be greyed out with a tick, if that makes sense.

Bol
Valued Contributor

I believe (might be wrong) unless user creation is completely handed off to setup assistant during enrolment, then filefault needs to be enabled upon login of that user.

Bol
Valued Contributor

There's a known issue where the recovery key isn't escrowed to mdm when FV is enabled during setup.