Imaging new Macbook Air 13" and enrollment issues

New Contributor

We have received several Macbook Air 13" computer recently and created a new 10.8.4 image to run on these. While deploying the image using Casper Imaging and usb to ethernet adapers and local thunderbolt ssd distribution points we have found that when adding QuickAdd to the configuration the computers will fail to enroll in the JSS. We have experimented and have found that if we use a thunderbolt to ethernet adapter we have some that will enroll and some that will not. I am attaching the jamf log of one of the computers that failed to enroll. We have imaged several older Macbook Airs this summer with a different 10.8.4 image and have not had any issues with enrollment. But since we purchased the new Macbook Airs we have had to create a new image that will work with this new hardware and this is when the issues began.

Jamf log:
Mon Jul 1 08:22:10 No Name jamf[4789]: Installing QuickAdd.pkg...
Mon Jul 01 08:22:11 macbookpro-10ddb1ce8245.local jamf[4823]: The SSL certificate for does not need to be trusted.
Mon Jul 1 08:22:12 No Name jamf[4856]: Checking for policies triggered by "any"...
Mon Jul 1 08:22:12 No Name jamf[4856]: Could not connect to the JSS. Looking for cached policies...
Mon Jul 1 08:22:12 No Name jamf[4789]: Installation failed. The installer reported: 2013-07-01 08:22:11.276 installer[4815:5b03] Package /Library/Application Support/JAMF/FirstRun/PostInstall/Resources/QuickAdd.pkg uses a deprecated pre-10.2 format (or uses a newer format but is invalid).
installer: Package name is QuickAdd
installer: Installing at base path /
installer: The install failed (The following installation step failed: run postflight script for QuickAdd. Contact the software manufacturer for assistance.)


Honored Contributor II
Honored Contributor II

Are you doing your imaging with Casper Imaging, or are you using another method? I'm asking because I guess I don't understand why you are applying a QuickAdd package to a machine if it is being imaged with Casper Imaging. The machine should be enrolled to the JSS as part of the imaging process.

I have 20 of the new MBAs that I am imaging, and I've done 5 so far with no problems. I did have to create a new NBI for these machines, but once I did that and added the machines to Pre-Stage, I was off and imaging.

Have you tried removing the QuickAdd package from your imaging?

Valued Contributor II

Based on the message "Mon Jul 1 08:22:12 No Name jamf[4856]: Could not connect to the JSS. Looking for cached policies..." it seems as though the computer isn't able to communicate with the JSS for some reason. Are the systems connected to the network throughout the entire (initial imaging and first boot) process? I would second what @stevewood is saying about the need for the QuickAdd package if you are using Casper Imaging to image the computers. It really shouldn't be necessary.

Valued Contributor II

"could not connect to the JSS" was the root of my problems in this post

JAMF had to give me a custom script to check for JSS connection and then enroll again if necessary...

New Contributor

We had some enrollment issues earlier this summer enrolling without Quickadd in our config so JAMF told us to add the QuickAdd to our config. We are not netbooting, we are booting off of a external thunderbolt drive and using it as our distribution point. Our laptops are connected to the network with usb to ethernet adapters and have a connection during the whole imaging process with Casper Imaging.

Contributor II

Ah, the USB - Ethernet adapter could be a red flag, is it possible to test USB based HD and thunderbolt based ethernet and see if you get the same results?

My thoughts are that the USB-Ethernet adapter has not quite gotten network when the QuickAdd package is being run, thus failing. You may need to create a custom script with a built in timer to wait X number of seconds before running the QuickAdd package. When I have things that rely on network connectivity that time to time fail, i can almost alway pin it on the USB ethernet adapter.

Valued Contributor II

I was wondering the same thing. The thunderbolt or USB ethernet adaptors take forever (more than 5 seconds) to connect.

New Contributor

As of 8/16, we're still having this issue as well. Built a new image based on 10.8.4 with Casper 8.71 and all of our other machines (iMacs/MBPs on 10.8.0 image) image and enroll fine. We were having issues where our machines were not enrolling, but we added the QuickAdd Package and that fixed it for Mountain Lion. However, the very same QuickAdd package on these new MBA + 10.8.4 image fail with the exact error you're getting.

However, I've noticed that once the imaging is complete, if you run something like;

sudo installer -pkg /CasperShare/Packages/QuickAdd.pkg -target / -verboseR

It actually will run and enroll. So if you call it from the command line, it has no issues. I tried to call it from the command line during imaging thinking it would work and it laughed at me and did not work-- it only can do it after the imaging process is over, which is just mind boggling.