In House App Issue

New Contributor

Hi All,

I am having a small issue since moving over to a different Casper server. Our in house applications aren't being installed as they once were. I am receiving a message stating that the application cannot be installed at this time. I have tested on installing the in house applications via Self Service and installation with prompt. Confirmed that the apps were managed as well as well as a good Wifi signal. Any help would be appreciated.


Contributor II

Are you storing the in house .ipa file on a web server? Double check the URL to the .ipa file. Make sure you are pointing to the correct location from the JSS. The only times I've seen this error message was when I had a typo in the URL. Fixing the URL worked for me.

Hope this helps!

New Contributor

I'm having the same problem after installing our new certificate. The .ipa is on the same web server, I've removed and re-enrolled one of the iPads and, while I can see the in-house app, it remains in the pending state while downloading. If I close the Self Serve app, the home screen shows the app without the icon and has "waiting..." beneath it.

New Contributor

I'm having something similar with our state's testing app. I put the .ipa file along with the config file on the JSS server. The app is set to auto install. I end up with a dark icon that has the name of the app, and a message saying, "Unable to Download App". I've tried it on a couple of iPads with the same result.

New Contributor II


Was there any solution provided for this? I'm still getting the same thing with an in house app.

New Contributor III

@aswain this is the fix.. it helped me out

The Fix