In-house app stuck on "installing"

lfrances
New Contributor II

Hello all,

We have an in-house (NOT Apple Store) app created by a third party developer that we push to about 91 devices, meant to be used as audioguides for our organization's visitors (museum). A few days ago, the app just stopped working and the devices showed a "guided access app not available" message. I uninstalled the app as a troubleshooting measure, and have not been able to reinstall it since. It just hangs at "installing" (under device History). What I have done so far:

Took devices out of Single App Mode, removed app and tried to reinstall with no luck
Renamed the .ipa
Requested a new, re-signed .ipa file and pushed the app again (worked, but only for a couple of devices)
Verified devices are on our wifi network
Updated and rebooted Linux server
Updated JAMF to 10.19
Checked all certificates, etc. – everything is up to date
Verified licenses available
Checked device storage – plenty of space

What makes things even more weird is the app pushed fine to a test device I have sitting next to me (I am not in the same location as the devices in question). I had also verified this device was having the same issues as the others prior to the app being re-signed.

I'm in contact with JAMF support who are additionally stumped.

This happen to anyone else?

Thanks everyone for the help.

EDIT: I have also tried a different wifi network, and updated to the newest iOS. Issue persists.

6 REPLIES 6

mark_buffington
Contributor

@lfrances - My first guess is that something is wrong with the provisioning profile embedded within the app. Either it's expired/invalid or the devices aren't able to reach out to Apple's servers to validate the profile when the app finishes installing.

After apps are installed, an in-house app needs to have it's embedded profile validated against Apple's servers periodically. I believe this happens naturally on iOS at the time an app launches, at unknown/undocumented (that I know of) intervals. Jamf Pro sends a periodic MDM command to validate in-house apps, which helps keep validations current on the device.

To check these things in your environment, there are a couple options:
- Rename the .ipa file to end in .zip, then expand the contents. Ctrl-click on the app and "Show Package Contents" and find and view the embedded.mobileprovision file.
- Make sure that the devices are on a network that can reach the host ppq.apple.com over port 443, per the KB: Use Apple products on enterprise networks

besecksw
New Contributor

This is happening to me today with 2 ipads but I am only installing free apps from the Apple School Management application. It's crazy. If you tap the app, it says "Unavailable to install <appname>. You must purchase the app to install it. I have tons of licenses for these apps and they were free.... it's happening with apps like Google Classroom, Pearson's Testnav, etc. No rhyme or reason at all that I can see.

lfrances
New Contributor II

@mark.buffington Thank you for the insight. I can't open the file, but looking in the info tab it appears nothing is expired or invalid, but I can't know for sure.
Interestingly, it does say "app not validated on xx/xx/xxxx" and when I force validation nothing happens.
7084830402484f908095f8b869274de5
Also interestingly, the app will install and load on a device I have here with me, but not at the location I need it to (I'm remote). So I'm going to go out on a limb and test it on a different wifi network.
Also, how do I make sure that the devices are on a network that can reach the host ppq.apple.com over port 443? Sorry, I'm still a bit new to all this.
Also, this happened completely randomly so there's that..

mark_buffington
Contributor

@lfrances - The validation part not completing makes me think this is likely an issue with the network the devices are on.

A good way to check the network would be to use the Terminal.app while connected to that network, (which I understand may be difficult for you being remote to the site in question.) A command can be entered there which should give a simple success/fail response:
nc -z ppq.apple.com 443

lfrances
New Contributor II

@mark.buffington I just checked the network and I got a message that the connection was successful. Hmmmm....
I was thinking it was something to do with the distribution point, but I'm not sure how to check.. that also doesn't tell us why the app just stopped working..

nicktruden
New Contributor II

This is an issue several users are having. Jamf, can we please take a deeper look into this?