ipa upload failing in JamfCloud

New Contributor

Hello Everyone,

I've been working with an outside developer on creating an in-house application for our organization. I've been uploading to jamfcloud and doing test deployments to devices without issue the past 2 weeks. They provided a new xarchive, I packaged, and now all of a sudden I'm getting "Upload Failed" when uploading the IPA. This happens after about 20 minutes of "Pending Availability". I've tried multiple different IPA files, different names, different settings, etc. Nothing is being uploaded.


New Contributor

Were you able to fix this? We're facing the same issue uploading an in-house App. 

The "Test" version of the App can be deployed without issue, but the production App ended up with this issue. We've seen the issue in the past and it started working after a few weeks. 

Now we're trying to update the app and it went through the 20ish minutes of "Pending Availability" and Upload Failed. I've tried to rename the IPA and upload again, same error, but the upload failed now comes in a matter of seconds instead of minutes.