iPad passcode auto lock not working?


Hi everyone,

I've setup a payload under passcode, given maximum auto-lock time is 15 minutes.
However, on my iPad it's still locked in 2 minutes(by default) and the iPad allows user to modify the time as they like.

Is there any way to disable the setting to prevent users in changing the time, and iPad will lock at 15 minutes according to the payload?

I couldn't find much information of this issue.


New Contributor

Same here. The ipad is locking way to quickly. I did notice the never option is going in iOS as well. But 15 minutes would be fine if we could get this configuration profile to push out the setting to the ipads correctly.

New Contributor III

Hi reon,
I think you have the answer in your post.
When you set the MAXIMUM auto-lock time to 15 min, you allow users to set auto-lock time to 15mn MAXIMUM.

You do not set the time but the maximum time.

Casper allows 4, 3 or 1 min, but iPad not, so you will see 2min for values under 5min.

New Contributor II

Oh dang. This makes good sense, and explains the many various troubles people keep reporting with this feature.