iPods Do Not Set Time Zone

el2493
Contributor III

We recently added a bunch of iPods to Jamf via ADE. In the Prestage we set the Time Zone, but users have reported the time is not correct and in almost all of the iPods if we look at the Management tab we see Settings - Time Zone as Pending. On one iPod it shows as Failed with the message The setting being applied is restricted.

 

We do have a Profile on the iPods with the Restrictions payload. Does anyone know what specific setting might be restricting this? We do have Automatic date and time - Enforced, but I wasn't sure if that could cause the problem. I looked through the rest of the Restrictions payload and didn't think I saw anything related to time.

1 ACCEPTED SOLUTION

Jay_007
New Contributor III

I'm also not familiar with iPod management, but if you have "Set Time Zone" enabled in the PreStage Enrollment and "Automatic date and time" Enforced in the Restrictions payload, it can cause a conflict. I'm unsure why this is, as you would expect the PreStage Enrollment settings to reach the device before any Configuration Profile. Basically the Restriction is blocking the PreStage setting.

View solution in original post

3 REPLIES 3

RLR
Valued Contributor

Not familliar with iPod setup but usually location services has to be enabled to set the time correctly. Is location services turned on?

Jay_007
New Contributor III

I'm also not familiar with iPod management, but if you have "Set Time Zone" enabled in the PreStage Enrollment and "Automatic date and time" Enforced in the Restrictions payload, it can cause a conflict. I'm unsure why this is, as you would expect the PreStage Enrollment settings to reach the device before any Configuration Profile. Basically the Restriction is blocking the PreStage setting.

el2493
Contributor III

Thanks, a few weeks ago I ended up removing the "Automatic date and time" Profile while testing and confirmed the Settings - Time Zone command did go through (sorry, forgot to post update here).