Issue with Fileshare DP and JSS

New Contributor

Hey everyone. So..I've got an issue regarding JSS connecting to a file share and I'm running out of ideas. Setup/issue is as follows -

The setup
JSS hosted on a mac (version 9.81), and currently setting up an smb fileshare on a separate mac.

Folder has been created on the separate mac, with file sharing enabled - casperadmin user with read and write privileges and casperinstall with just read. Server/smb details have been entered into JSS within the file share settings.

The issue
When trying to use Casper Remote with this particular DP it does successfully mount the share, but then can see nothing at all within the share itself. However, if I mount the share manually (still using the casperadmin or casperinstall user then I can see everything.

I've tried setting up a new share on a different mac and following the same process though still the same issue occurs. I've changed the permissions on the share itself and the files within it and changed the owner/group to various things but no luck. So far there doesn't seem to be much in the numerous system logs, apart from it stating that the connection itself was successful (and even less in the JSS logs).

Theoretically the information within JSS must be correct, as it can successfully mount the share, and permissions should be all good as using the same casperadmin/install credentials I can mount the share and see everything within the folders.

Any suggestions would be greatly appreciated!

Thanks in advance!