Issue with Printer Drivers

New Contributor II

I've deployed and installed all HP and Kyocera printer drivers to the Macs. Our printers are older models too, and if I add a printer I still get this pop up. Anybody have any solutions to not have them go through this process?

external image link

Also having an issue adding Printers now in Self Service
, they don't show up until RESTART.


Valued Contributor II

The only time I've seen the error message above is when the printer software is either missing or has some permission type errors with the files. Have you tried manually re-installing the HP Printer Drivers v.2.16.1 for OS X package on the client computer to see if it makes any difference? Also a repair permissions might be in order as well. It looks like you are sharing the printers using a server, do you get the same error message if you try and connect the client computer directly to the printer via IP printing?

The issue you are having with adding printers via Self Service is a known defect. Check out the response at for a possible work around.

New Contributor II

I did reinstall the drivers, but it doesn't seem to make a difference. Not quite sure why it's asking me that.


I am having the same issue adding a printer to one of our iMac (some 10.8, most 10.7) labs. When I test the policy on my Macbook (10.9) it works though.

My original printer policy was only mapping the printer, which I added to Casper Admin on my Macbook. This worked initially, but whenever I manually run the policy via terminal on the iMacs, it completes without any errors and there are no errors in the JSS logs but the printer just isn't there.

My most recent approach was to capture an installation with Composer of the HP software from their site. I get to the point where it asks to add a printer so I select the lab printer. I tried this through bonjour and also the ip address. It then says it needs to download the software from Apple Update but after some time it says it cannot contact the server or the printer refused the connection. I had some issues downloading the software initially from HP; it took me multiple tries to get the download page to actually load, so I wonder if when it downloads the software when adding the printer if it is timing out when contacting the HP site for software, even though I just installed it and am adding the printer from the installation wizard of the same software.