Issues removing Meraki Systems Manager

New Contributor II

Has anyone had any issues with Meraki not letting go of certain devices off of their network? Our organization has been using Meraki and Simple MDM to manage all of our macs and we're in the process of moving everything over to Jamf. Some devices have been a breeze and have had no issues leaving their current MDM and enrolling with Jamf, but I've had a handful of Meraki machines that won't allow me to remove the config profile. The minus sign is completely greyed out in system preferences (even as a local admin), specifically for Meraki Systems Manager. The other config profiles are completely removable with admin rights.

Here's my normal workflow - Remove the device from Meraki Dashboard, Remove the config profiles from System preferences (if it doesn't do it automatically),
Assign the device to Jamf in Apple Business Manager (DEP only),
User-initiated Enrollment with Jamf.

For the handful of times where I'm unable to remove them I've tried a few different scripts I've found on Jamf Nation and I've tried running the uninstaller pkg from Meraki, but still no luck.

I reached out to Meraki Support and they told me that the only option left is to do a complete erase and install which I would prefer not to do.

Anyone ran into this before or have any ideas?


Valued Contributor

New Contributor II

@sshort Thanks for sharing that! Temporarily disabling SIP allowed me to remove the meraki profile and add the JAMF management profile.