Issues uploading "Install OS X El Capitain" to Casper Admin


Hi All,

I'm just seeing if anyone else out there is having problem uploading the OS X El Capitain Installer to Casper Admin where the primary distribution point is cloud and an Amazon S3 bucket?

I can see the upload happening and if I check the S3 bucket with the Amazon CLI command line I can see it, as soon as it gets to the end of the upload it either a) crashes Casper Admin b) Uploads then I set a category, Save it to Jamf Software Server and quit and re-open Casper Admin it now says Missing in red text.




Honored Contributor II
Honored Contributor II

@Sachin_Parmar I do not use a cloud distribution point, but what you describe is what I see using a JDS whenever we upload large packages. Because the package goes to the database BEFORE transferring to the JDS, I have to leave Casper Admin open for an extended period of time (10 to 20 minutes or longer) to make sure the package actually gets there.

I've taken to checking the database to see if the file has completed transfer from the database over to the JDS using mysql commands:

use jamfsoftware; 
select count(*) from downloadable_files;

Once I see that the select statement returns 0, I can close Casper Admin.

It is one of the things I dislike about how the JDS behaves.


@stevewood Thanks for the comment, I don't think I've got direct access to the mysql DB as i'm on a JAMF Hosted solution. I agree it's not the best method, I tested a work around today by making my local DP a primary DP and then uploading it to that went through no problem, under a minute, tried to replicate to AWS same problem. I'll try an upload again and leave Casper Admin open for a long time hopefully that would help

Contributor III

@stevewood We see exactly the same issue with JDS since the 9.82 update. we have a work around in that once the pkg is loaded into Casper Admin we also copy the same pkg to the CasperShare on the JDS.

Really doesn't seem to be a size issue but more a sync issue between the JSS and JDS, if there was a manual way to sync it might be a better solution.


Not sure what the behaviour is on a JDS but for Amazon (and Rackspace) you might be having issues related to file-size limits for single files (5GB).

See here:

I use Rackspace and I have been able to do a similar thing as @dmw3 describes, where I upload the file directly to the share using Cyberduck and then also use Casperadmin or JSS upload. Kinda counter-intuitive but seems to work.

New Contributor II

@Sachin_Parmar , I might be able to totally help here.

I'm on a JAMF hosted solution, with AWS S3 set as my master distro. for almost a year now.

I upload not only OS X installers, but LARGE .dmg's (4-8 GB, I've had a couple 10 and 12 GB dmg's)... we are an audio production company and we have a lot of software instruments that I have to deploy installers for.

Concerning your trouble uploading the installer:

  • Upload speed - our office works on a very slow upload speed, and I always have trouble getting these larger uploads/installers to stick. My home connection, however, is a fiber connection (100 x 100), so I always push these larger ones up over my home connection with little to no issues. If you're running up these larger installers to AWS (via Casper Admin), on an upload speed lower than 25MB, you'll get problems most of the time, or at least that's what has happened in most of my instances. Of course, as always, results may vary.

  • There is a legitimate, what I like to call, "cooling off" period that these large dmg's need to take on AWS, before you can start working with them. After I upload these large dmg's, I then just hit "Save" in Casper Admin and then quit Admin, and then walk away. (don't even set a category). I usually come back an hour or two later and it's "cooled off" ready to go... then I start working with it. Even if you reopen Admin right away, you'll see the red "missing" indicators, but if you close Admin, then come back later, it will sort itself out.

Also, using a local distro, to replicate/push up to AWS, will yield the same results... everything still needs this "cooling off" period.

I've also tried FTP-ing into the S3, and then trying to do what others have mentioned here, but that just didn't really work for me, and it seemed like much hassle.

Yes, there will be times when Casper Admin will crash randomly... esp. on these larger uploads.... but, in my situation, with the 100MB up speed, and the cooling technique, I've been pretty near good for several, several months.

My hope is that Casper Admin becomes a lot more robust, and will integrate better with cloud distro's/AWS in the future. From what I've read around JAMF Nation, there's a lot to be improved on in Admin, so here's for hoping for the best!


@reelmike are you still doing this method? Im trying this now. i just uploaded to my aws cloud DP. saved and closed casper admin. When i opened it up its RED and says that its missing. Its only been a few minutes. i will wait an hour or two and check again.