Jamf Cloud enrollment customization issues

markacorum
New Contributor II

Hey all, 

Hoping to get pointed in the right direction here since I can't seem to figure it out after reading through documentations and opening a help ticket.

I am currently trying to get my Enrollment customization working with Okta. I have Okta set up in SSO and Azure AD is set up as my cloud identity provider and both seem to function properly. The issue is when using Enrollment customization it is not autofilling my user info on the computer record. I am trying to not have to manually assign a user to device if possible. Does anyone have any recommendations on what to try?

Worth noting I have tested the fill last logged in user and that seemed to place the user ID in the username field but it didnt allow it to auto query Azure AD for the remaining info (email, Department, phone number, etc...)

8 REPLIES 8

jphillips
Contributor

We're in a similar boat. We are using Azure as IP and when I tested enrollment customization, the same thing occurred: it did not put the enrolling user's username in the iPad record's username field, which we absolutely have to have.

mdcooledge
New Contributor II

I seem to be having the same issue. Any update on a resolution?

unfortunately not, it really messes with my 0 touch deployment. 

mdcooledge
New Contributor II

I contacted Jamf Support, we had to make changes on our Azure side of things. Recommend reaching out them if you still are having issues. 

markacorum
New Contributor II

that gives me hope! Just to confirm, you have Okta set as your Jamf SSO and Azure set as your cloud Identity provider?

mdcooledge
New Contributor II

We have Azure setup as our SSO. 

mfletch
New Contributor II

Hi, all, any update on this? I have Okta setup and I can test looking up users and it works fine, but when I switch enrollment customization from LDAP authentication to Single Sign on and enroll a device it enrolls fine and all profiles and policies apply correctly, but the User information does not populate. I can edit the user information and search for the user and assign that way, but obviously that's not ideal. I feel like I'm missing a check box somewhere but I can't seem to find it. Any ideas? 

markacorum
New Contributor II

no update that I am aware of. From what I understand this feature only functions if Azure is the only piece associated and not okta mixed with Azure