JamfDaemon high memory usage

New Contributor

One of my client is reporting high memory usage on his computer. memory usage gets higher ans higher as it's goes on. any suggestion of how to stop my client's from crashing. it's checking in every few seconds.

I keep seeing this on the jamf log:

No patch policies were found.
Checking for policies triggered by "recurring check-in" for user
Checking for patches...



New Contributor III

Had this issue a week ago - open the console app and look for jamfdaemon, this should clarify which app is causing the problem.

In our case it was a scientific app called “IGV” which you can download and install in two separate ways:

  1. App including Java JDK = Jamfdaemon runs amok

  2. App only and separate Java JDK installer = Jamfdaemon runs fine again

Try to figure out the “broken app”.


New Contributor

Similar issue here with MATLAB today. Played nice until my user did a 2D visualisation of well plates. jamfdaemon goes absolutely nuts, and Console shows some fun things happening a LOT of times per second. Up to 22GB RAM very quickly.

New Contributor III

@oweban Yes - that’s exactly what we’ve been seeing with IGV and in our case the only solution was to install the Java JDK separately. Not sure if MATLAB is also using Java in background.

New Contributor

Did you have a fix on this issue? Facing same issue but no response from anyone and couldn't find this topic troubleshooting in google.


Valued Contributor II

Do you use Absolute? We had to turn off expanded reporting and that addressed our issue

New Contributor II

I opened Case #: JAMF-2980546 for similar issues since we updated to 10.30.1

New Contributor II

@psaintemarie any updates from JAMF on you open case? Seeing the same issue on several machines here, running Matlab. Using 100+GB of memory.

New Contributor III

Second App (GSEA) - same error!

Seems like the jamfdaemon doesn’t like apps which have already a Java JDK included in the App itself. But this time it’s not just the memory running amok - it’s also the CPU usage.


We have seen the same issue since updating to 10.30.1. For us, adjusting the recurring check-in time from 5 minutes to 15 or 30 minutes seems to have made the issue better, but I've also put in a support ticket with Jamf for this.

Edit: Jamf replied this is an issue with application usage logging, disable that and it should help until there's a new version ready.

New Contributor II

We just started to see this on 10.30.3 with MatLab. Never noticed it before but disabling the Applications Usage Logging seem to help for now. Were there any other updates yet from Jamf

Unfortunately not!