java 1.6 for fresh installs

sietsemaeri
New Contributor III

Sounds dumb, but I am looking for for the java 1.6 download for a fresh install of JSS.

Thanks

1 ACCEPTED SOLUTION

sietsemaeri
New Contributor III

I was working on a fresh install and that was the message that was prompted to me was for 1.6, I have been looking for a direct link to do the java install, I thought it would have been in the release notes for JSS but I have not found it.

View solution in original post

10 REPLIES 10

millersc
Valued Contributor

dgreening
Valued Contributor II

You might want to go with Java 1.7/1.8 due to this in the release notes for 9.92:

Java 1.6 compatibility—Upcoming releases of the Casper Suite will be incompatible with Java 1.6. It is recommended that you start using a later version of Java.
If you need assistance with the transition to Java 1.7, or if you have questions or concerns, contact JAMF Software Support.

john_miller
Contributor

Hey @sietsemaeri

Thanks for posting.

As @dgreening mentioned, I'd highly advise moving to 1.7 or later. We've deprecated Java 1.6 and will stop supporting in forthcoming releases, requiring a higher version for the JSS.

Are there reasons or features in 1.6 that are required in the your deployment? Can you share more of the details around why Java 1.6 is needed?

Thanks!

sietsemaeri
New Contributor III

I was working on a fresh install and that was the message that was prompted to me was for 1.6, I have been looking for a direct link to do the java install, I thought it would have been in the release notes for JSS but I have not found it.

View solution in original post

john_miller
Contributor

Ah got it.

Well go through and make sure to update any references but as mentioned, feel free to use 1.7 or 1.8.

Thanks!

mconners
Valued Contributor

@sietsemaeri There are some apps that require JAVA 1.6 as I already have the latest 1.8 installed and they refuse to work. For those, I lean on the Apple JAVA Link to download direct from Apple. Currently, I am trying to clear those out of the JSS, but there are a couple of oldies out there that simply refuse to work with JAVA 1.8 u91, or any older version for that matter except JAVA 1.6.

https://support.apple.com/kb/DL1572?locale=en_US

Hopefully this helps a bit.

scottb
Honored Contributor

Indeed, some houses use older software that still prompts for the Apple J6. Adobe CS6 for one...

easyedc
Valued Contributor II

Per page 13 of the JSS Installation and Configuration guide for Linux 9.92, JAMF supports running a JSS on: Red Hat Enterprise Linux (RHEL) 6.4, 6.5, 6.6, or 7.0

According to our Linux Server team the latest java published for RHEL 6 is Java 1.6. Apparently, there is no 1.7 in the RHSCL channel either. Can @jamfsupport verify?

rtrouton
Valued Contributor III

@easyedc,

I'm using OpenJDK 7.x on RHEL 6.x. Installation instructions for RHEL and other Linux distros are available from here:

http://openjdk.java.net/install/

easyedc
Valued Contributor II

@rtrouton I took the plunge and installed it on my test server running:

java version "1.6.0_38"
OpenJDK Runtime Environment (IcedTea6 1.13.10) (rhel-1.13.10.0.el5_11-x86_64)
OpenJDK 64-Bit Server VM (build 23.25-b01, mixed mode)

on

Red Hat Enterprise Linux Server release 5.11 (Tikanga)

and it worked without issue. I am definitely behind on my RHEL release, and I accept that as a variable that is fixable but in our environment changes are not easy to make/implement, so it's a battle I've not had yet. I know at some point I'll need to get my servers updated and migrated to newer OS's. Maybe later this summer.