JDK 8 u73

mconners
Valued Contributor

Hi Everyone,

Has anyone been successful in packaging the JDK 8u73? I have tried to just drop the .pkg into Casper Admin and I have tried to snapshot it with Composer. Both methods fail to deliver an installer that works via Casper Remote or via policies.

The initial "Drop the package into Casper Admin" works as part of the imaging process. The package fails at about 95% when installing in any other method of installation.

This is strange and not sure what to make of it.

Thoughts?

Mick

8 REPLIES 8

Aziz
Valued Contributor

You exported the .pkg inside the .dmg? That .pkg is all you need.

optional image ALT text

djwojo
Contributor

Never mind... Read too fast and missed JDK.

mconners
Valued Contributor

Correct. I opened the DMG, then dragged the .pkg from inside of it to Casper Admin and completely copied to Casper Admin just fine. When installing via policy or Casper Remote, it fails to install at about 95% completed. I thought this would be easiest thing to do. I didn't drag the .pkg to my computer, just directly from the opened disk image to Casper Admin.

Aziz
Valued Contributor

@mconners Can you check console for any errors?

mm2270
Legendary Contributor II

What happens if you manually install that same pkg on a Mac? Or install through Terminal and throw in the verbose flag?

/usr/sbin/installer -pkg /path/to/JDK 8 Update 73.pkg -tgt / -verboseR

Do you see it error that way as well?

mconners
Valued Contributor

Great ideas guys...let me dig a little deeper to see what I can find. Thanks!

SGill
Contributor III

Edit: sorry you were mentioning the JDK not the JRE...I had good luck deploying 74, didn't test on 73.

About the JRE:

I saw those same errors too, but it was because I had accidentally attempted to deploy the enclosing metapackage. It appears that one will fail due to end user response required.

The package "JavaAppletPlugin.pkg" in the Resources folder will deploy fine. I had to use the "Show Package Contents" approach that has been mentioned in other threads here.

mconners
Valued Contributor

Interestingly, I tried this again and it worked! The only things different is I had copied the .pkg to my desktop and the install was done via Casper Remote without anyone logged in. I cannot tell you if I was logged in before.

It's one of things you keep trying and trying and I didn't document the precise differences between each try. So it looks like this might work. I am going to try some more tests.

The ONE error I did get was when verifying /usr/sbin/jamf... it failed to verify as it didn't exist. It did successfully install it though so I believe I am good to go. Thanks for the advice as always.

4ee4e3e333904db1a870e238cf2d79cb