JDS on newer Ubuntu versions?

DanJ_LRSFC
Contributor II

Currently on Ubuntu the JDS is only supported on version 12.04, which will be exiting support later this year (2017). Does anyone know if JAMF have any plans to update the JDS system to support newer Ubuntu versions, for example 16.04 LTS?

Thanks,
Dan Jackson (Lead ITServices Technician)
Long Road Sixth Form College
Cambridge, UK.

8 REPLIES 8

al_platt
Contributor II

We use Centos but amend as below. Maybe try the similar for Ubuntu?

echo "Red Hat Enterprise Linux Server release 6.5 (Santiago)" > '/etc/redhat-release'

DanJ_LRSFC
Contributor II

@al_platt I don't think the situation is as simple as that with Ubuntu as there are architectural/package changes which impact the software. What I'm suggesting/asking is whether JAMF will be releasing an updated JDS which will support supported versions of Ubuntu after 12.04 support ends this year.

davechristensen
New Contributor II

Would love an update on this situation as well. It can be made to work under 14.04, but obviously that is an unsupported configuration. 16.04 has larger differences - haven't tested it yet.

DanJ_LRSFC
Contributor II

I take it there's been no update on this situation? Ubuntu 16.04 LTS is out and 12.04 has exited support, so we'd really like to transition to a newer version.

nmanager
New Contributor III

According to the admin guide version 9.99.0 will run on both 16.04 and 14.04. http://docs.jamf.com/9.99.0/casper-suite/administrator-guide/Requirements.html
Tested operating systems include:
macOS 10.10
macOS 10.11
macOS 10.12
Ubuntu 14.04 LTS Server
Ubuntu 16.04 LTS Server
Red Hat Enterprise Linux (RHEL) 6.8 and 7.3
Windows Server 2012 R2
Windows Server 2016

I am running 9.98 on 14.04

mbinkley
New Contributor

The full version of the JSS runs on newer versions of Linux but if you dig through the documentation the JDS installers still do not support anything higher than 12.04 LTS.

ak2143
New Contributor

Just some additional info on this, I entered a support ticket and got this response from support.

"At this time, we only support the JSS on 16.04, but not the JDS. The JDS will not actually install on 16.04 and we do have a feature request to line up the functionality of the JSS and the JDS support."

davechristensen
New Contributor II

Upvote the feature request!