Laptop disabled after too many incorrect lock password entries

New Contributor III

Before winter break, we locked any laptops that were not permitted to be taken home. One student thought it would be fun to try every password he could think of to unlock his laptop.

When the laptop boots, we see the following message:
Your computer is disabled. Try again in 60 minutes

After the timer runs out, the laptop reboots and starts the timer again.

We have tried booting to an external drive to re-image the laptop, but it just restarts the timer.

We have also tried sending an unlock and a wipe command through JSS, but those don't work either.


New Contributor III

Update - Booting into Internet Recovery brought up the passcode prompt again. We were able to unlock the laptop.

New Contributor

The same situation happened to me today. I tried to input the passcode several times, now there is no place to enter the 4-digit passcode. Have you found any solution to that now?

New Contributor II

Internet Recovery mode did not work for me.

New Contributor III

We have had the same issue (twice). The only resolution is to call Apple and setup a Genius Bar appointment. You will need a proof of purchase with you, before the work on it. The will need to reset the firmware.

New Contributor

If you have the firmware code, there is a way to clear this (mother f'ing) non-functional "Your Computer is Disabled" count down screen loop. Either take your laptop and proof of purchase to an Apple store or try the following:
I will attempt here to create a Step by Step. You will need two USB sticks.

1] On one stick create a mac OS installer using DiskMaker X (I tried it first with a High Sierra version and it did not boot all the way. Then I tried an older one I had with El Capitan on it and it worked) You will need to google DiskMaker X and learn how to make this needed USB stick. You have to do this on a second Mac. If you can't get El Capitan try it with a newer OS ... maybe I made a mistake the first time in all the steps with the High Sierra version. [edit] I tried following the steps with my High Sierra USB stick again and it seemed to boot all the way so give that a try first since it is easy to obtain the High Sierra OS.

2] (I did this part on my windows machine) On the second USB stick you create a bootable USB with rEFInd boot software . At this web site download the "A CD-R image file", not the USB version. This is an ISO file. Next you need a USB maker, I used Universal-USB-Installer- which I downloaded from Cnet Downloads. Run the USB installer, at the main window for Step 1 there is a drop down menu with lots of Linux choices, scroll to the bottom and choose "Try unlisted Linux ISO". In Step 2 point to your fEFInd iso file. Then select your usb drive and click Create. During the process the installer said it failed and would not be bootable, but I finished it anyway and the USB fEFInd stick worked.

3] Go back to your Mac, plug in both USB sticks and boot holding the Option key down. Enter your firmware code at the lock screen. Then select the EFI boot USB stick and boot to that. Then using the arrow keys select the mac OS USB installer that you made. (see screen shots below) Once that is highlighted, hit the F2 key. This will give you another boot options menu. Select "Boot macos in Singer User Mode". Your mac will start booting to a terminal or command line window. Wait until it has finished scrolling out many lines of startup data, and you are at a command prompt. Then type in this succession of commands:
nvram -c
nvram -xp
nvram -c
nvram -c
nvram -c
nvram -c
nvram -xp
Yes you need to clear the nvram several times in a row! (nvram -xp just lists what is in nvram)
Then type in exit and wait. The laptop should continue booting in that command window until it switches over to the GUI window and you end up at the general OS Installer window. The installer window for El Capitan and High Sierra have a utilities section and the Firmware Password Utility is included. The window using High Sierra calls it the Startup Security Utility. I opened the utility and turned off the firmware authentication using the code ... [at this point I was totally psyched, as you will be, because I had been working on this for several days, including multiple calls to Apple where they told me I had to come in with my proof of purchase (which I did not have anymore for this 2015 mac passed end of warranty, sokeep your receipts!) if I wanted them to clear the Disabled Computer issue.

4] Next I erased the disk using Disk Utility and did a clean install of the OS. (It occurs to me that many of you may not want to wipe the laptop. In this case skip wiping your disk and try shutting down and removing the USB sticks. Then do a nvram & pram clearing boot as follows:
Shut down your Mac.
Locate the following keys on the keyboard: Command (⌘), Option, P, and R.
Turn on your Mac.
Press and hold the Command-Option-P-R keys immediately after you hear the startup sound. Hold these keys until the computer restarts and you hear the startup sound for a second time.
(if your laptop does not chime, just hold them down after pressing start as quickly as you can and hold until it seems to reboot again)

Please post to this thread if you can succeed without wiping the hard drive.
Good luck, MTFBWY

(note these instructions were based on a thread I read here: )

Here are some screen shots from the process:


New Contributor

Thank you rws70. After futile attempts to find my receipt. I was able to use this method to recover my Macbook Air

New Contributor

God bless You - rws70! Thank you very much! :)

New Contributor

There is a place in paradise for person like you. Thanks a zillion.

I also wrote another guide and mentioned you in the very first line:

New Contributor

i lock my macbook air using find my iphone, and now my macbook air is back/returned but they already make it blocked i cannot see the input PIN Code.
it only says Wrong PIN, please try again, if restarted it says to wait 60 minutes, after 60 minutes still showing "Wrong PIN, please try again" but no place to enter.

i did not set up a firmware password, i try the method above it was asking for firmware password what should i enter? my icloud password not accepted in this area, is it randomly created? (the firmware password?)

i need yo make PIN enter screen available again because i have many data inside i have not backed up yet, appleee why make it hardd like this, this is absurd i get my laptop back but i cannot open it... no place to enter PIN Lock

New Contributor

Hi - I am trying the method described above and I get stuck at Step 3 - Boot macos in Singer User Mode". Your mac will start booting to a terminal or command line window. The laptop starts to boot to terminal with lines of code running and then goes back to its locked OS. Any suggestions? I wonder if there is a way to boot from efi shell? It will enter that mode. Also when I tried to create GPT partition table as in fmantovani example I had no free space - partitions were already created. Maybe a way to wipe partitions and recreate?

New Contributor

I signed up just to let you know this worked, this bloody mid 2012 was driving me nuts!

THANK YOU!!!!!!!

New Contributor

Have not been back to this thread in a couple years ... thanks for all the kind feedback. So glad I was able to help!
You are all very welcome! :)
All the best,

New Contributor

Flip dude.

Your'e a life saver. I signed up just to thank you.

For my recovery, the universal USB installer didn't work (it wouldn't show up as a boot option) so I used Rufus instead which worked like a charm.

Thanks once again.

New Contributor

Hello everyone,

Thanks for the solution,
I tried the "Boot macOS in Singer User Mode" option but the terminal codes don't end, it becomes like the screenshot below. Any suggestions to fix it?

New Contributor II

@toaufik I also received the symbol you received with High Sierra and Mojave installer USB sticks on a MacBook Air 13" (Early 2015).

I only had success with a Sierra USB installer I made using the standard commands listed in HT201372.

The locked MacBook Air was running 10.14.6 and was locked with Jamf School MDM about three months ago. When it was finally recovered today I experienced the inability to unlock the device that others described.

This thread was indispensable in my resolving and regaining control of the device.