M1 MacBook Air Big Sur permissions problem

New Contributor

I am setting up new M1 MacBook Airs that shipped with 11.3.1. My set up includes creating three local accounts, two of which are admin accounts.

When the configuration starts, the screen immediately shows the "Other" login page. I just let it sit until the configuration is complete and all software loaded. Then I restart the computer. On restart, I see the accounts I created.

I log in as an admin and get messages saying that some extensions are blocked (like Sophos). I go to System Preferences,  open Security & Privacy and unlock the padlock with my admin user password.

When I click on the button to Allow the blocked extensions to be loaded, a small window pops up saying Security & Privacy want user xxxxxxxx to authenticate. I put in the password and the window just shakes me off. Same password that unlocked the darn padlock.

Same thing happens when I try to update to 11.5.1. To restart, I need to enter my admin password - just get a shake off.

Any solutions out there? I have a bunch of these to do and would like this straightened out before I get too far along.





Have you tried logging in with both admin accounts? 

Have you tried logging in with the management account? Maybe a config profile limited changing of certain settings to the management account?

Thanks. Yes, I have tried all admin accounts including the management account. 

I was going to wipe the machine and try something different and noticed when in Recovery - Terminal and entered resetpassword, the normal window opens, but it shows zero admin accounts. The system does not acknowledge any of my admin accounts.

Also, if I create a new local admin account with the management account, the OS does not recognize it as admin.