Mac OS 10.10.5 support

mjames
Contributor

Hey All,

We are running casper 9.65 (we prefer to NOT run the latest versions of software) - and we are testing 10.10.5 (we might have to run the latest version in the instance because of the security fixes)

We have discovered a multitude of issues with 10.10.5 and Casper 9.65. (mainly with rolling out packages and self service - JDP's won't mount etc, etc)

What I am looking to find out is if anyone has test 10.10.5 with Casper 9.7 or 9.71? Has it bee a similar situation? Are we going to need to update to 9.73?

Thanks in advance!

Matt

12 REPLIES 12

rquigley
Contributor

We're running 9.73 and 10.10.5 machines and have had basically no problems. I can only really advise that you might have a test JSS for these instances and have some test machines to play with to really know if it will resolve your issue.

Annoying I know but it might give the outcome you need unless it is a bug with the software that hasn't already been fixed.

apizz
Valued Contributor

Our client machines aren't having issues with 10.10.4, but we were having issues with our 10.10.4 Netboot set running Casper 9.72 imaging. After updating the Netboot set to 10.10.5 and Imaging 9.73 we've had 0 issues with imaging to our clients.

We are currently deploying 10.10.4 on our client machines because, like you said, we prefer not to run the absolute latest to avoid unexpected issues and bugs. We still haven't fully imaged all our machines, but so far nothing critical to report.

mjames
Contributor

Thanks for the info.

@rquigley Its good to hear 10.10. and 9.73 both work well together. And I think your right, we might need to build a test and just see how it goes.

@aporlebeke I will definitely keep your experience with 10.10.4 and 9.72 in mind when testing.

We may end up going to 10.10.5 and 9.73, I can't rule anything out (it is not my decision to make) - but I do know our preferred option will be to keep Casper off the latest release if possible. The security issues of 10.10.4 are a bit of a concern to us, which is why we are looking at 10.10.5.

robby_barnes
New Contributor III

I'm running 9.73 and 10.10.5 on just over 1,000 machines and haven't had any problems with the combo of the two

cdev
Contributor II

We just updated our Casper environment to 9.73 and the majority of our machines to 10.10.4... That said, those (including myself) that are running 10.10.5 are working perfectly. I've already got an updated base image for 10.10.5 in our test environment.

kish_jayson
Contributor

@mjames What issues have you been experiencing with JSS 9.65 and OS X 10.10.5? I'm in a similar situation where I simply cannot upgrade past JSS 9.63 until D-009351 (NAS) has been resolved. However, we haven't deployed OS X 10.10.5 to our users yet and I would like to know what I should be looking out for.

CasperSally
Valued Contributor II

We are 9.65 and can't upgrade either. We are just beginning to test possibility of 10.10.5 for clients. Will check on package deployment and self service. Curious what others see, too.

emily
Valued Contributor III
Valued Contributor III

alexjdale
Valued Contributor III

Interesting, we are on 9.63 and I haven't seen any issues with 10.10.5.

dmw3
Contributor III

We are running 9.73 and 10.10.5 on about 200 client machines with only one issue, when policy tries to restart after the install of 10.10.5 combo we see this error occur but not on all machines:

cdafb55e5cee4deabceaa8cb6af87058

mjames
Contributor

Using 9.65 and 10.10.5 we have been having issues with self service and Casper Remote mainly. (We have not tested far past that because we were testing a new base image rollout and could not use self service to install most of the apps)

Basically self service will fail immediately (unable to mount to the share), or it will sit for ages trying to verify the package and finally it will give a nil or empty path argument error.

The logs are reporting the following after failures.

-[NSFileManager fileSystemRepresentationWithPath:]: nil or empty path argument
or

Mounting jdp01 to /Volumes/CasperShare 2...
Error: Could not mount distribution point "jdp01".

When the same policies are working fine on 10.10.4 systems...

I tried unmounting Casper Share 1with " umount /Volumes/casper_share " - but terminal reports it is not mounted, and trying " rm -rf /Volumes/casper_share " does nothing either, it still tried to mount to CasperShare 2.

Update: And now that I have said all that.. it seems to be working fine this morning? I think a lot more testing is required from my end.

CasperSally
Valued Contributor II

Just as data point - I upgraded test workstation to 10.10.5 and self service seems fine in my testing.

9.65 windows JSS
Dist points OSX
Dist points are in JSS by IP and no funky char in passwords

Installed 3 packages via self service (AFP) without issue.