Macbook pro 2014 efi disabled Help

New Contributor

So i have my macbook pro 2014 that is efi disabled for 60mins. I got it from a co worker and i do know the pin but whatever startup option i choose it will just bring me back to the start up screen saying it is disabled for 60mins. Ill wait the 60mins and then it says wrong password. Ive searched all i can to get this laptop up and working. Only option i found helpful was netbooting a image to it but I dont have really any experience with it. I looked at all recent posts but no help. Im trying to see if i can run a netboot image off a usb because i dont have any servers. All i am trying to do is boot the image so i cant get to the firmware utility. Im a guy, at home, using wifi, and strugging to get this macbook back to life. any help would be great. Thanks


New Contributor

Please help

Contributor II

When you say the "efi is disabled" what are you referring to?

It sounds like it could be a management command pushed from the JSS.


If that's the case, you should be able to boot into the recovery partition and enter the code that was used to lock the machine.

New Contributor

So when i hold option key on start-up, i enter my 4 digit pin & i get one hdd choice which is EFI boot. Ive tried running a recovery disk assistant on usb, el captain on usb, and anything i could think of but it always brings me back to the disabled for 60mins screen. Even when i try running recovery on usb it will load for a quick second but then switches back to disables 60mins. Ive searched past posts on here and only solution i found to it was

1) Netboot. (Had to enter the passcode)
2) In the Utilities, there is a Firmware Password Utility. Opened it, told it to turn off the firmware password. Had to enter the passcode.
3) Restarted (believe it or not, had to enter the passcode again) and Netboot (again).
4) Ran Disk Utility - repaired rights, and fixed disk.
5) Restarted to disk. Guess what? Had to enter the passcode (again). Computer self started, pass code was gone.

Is there any way i can do all this with just a usb and no network server?

New Contributor III

I have never seen a message 'disabled for 60 minutes' on a Mac, only on iOS after you enter the code a few times wrong.
You mention the only option being 'EFI Boot' That is not good, normally it will read 'Macintosh HD'. I have seen EFI boot if you try to boot from a windows installer USB stick.

What is the expected format of the disk? one Mac partition? BootCamp? FileVault?

Is the data important? if not, boot to Internet Recovery (cmd-opt-R), (enter Firmware pin to boot) run disk util and re-format disk, re-install from internet. (or USB stick you prepared with the createinstallmedia script )

New Contributor

The only hard drive option is EFI Boot. If i try going into internet recovery, holding cmd-opt-R, it asks for my pin. After entering it, it brings me back to the 60 minute disabling screen. I've tried creating a bootable OS USB image but it did not load up, it went back to the 60 minute screen.

New Contributor

anyone have another solution?

Honored Contributor

Go to the Apple Store with proof of purchase and identification and they should be able to sort you out. If it was obtained from a coworker than speak with them to see if they can help you.