Machine needs restart before it will enroll with DEP

New Contributor II


Posted this a few times still not resolved. We currently enroll our MacOS devices via DEP. Its gets passed the Apple Setup and when it gets to the desktop the machine does not automatically enroll into our server or pull down Jamf binary. A simply restart of the machine fixes this issue. I've reset tomcat so many times. rebooted my server and change the push cert.

Please help me.



Honestly, it can be a variety of issues. It could be the network, the firewall, etc, etc. How is everything set up?

Also, how long after assigning a machine to a prestige are you trying to set them up?

New Contributor II


right now when i check the logs im gettting this

2019-02-28 08:48:01,190 [ERROR] [Thread-54 ] [PushNotificationUtility ] - Unable to send push notification com.jamfsoftware.jss.pushnotification.notifications.AppleMDMCheckInNotification@3740501a. Connection reset
2019-02-28 08:48:01,217 [ERROR] [neralPool-8] [APNSFeedbackConnection ] - IOException getting and entering feedback data: Connection reset at at at at at at at at at at at at at at com.jamfsoftware.jss.pushnotification.connection.APNSFeedbackConnection.getFeedbackData( at at java.util.concurrent.Executors$ at at java.util.concurrent.ThreadPoolExecutor.runWorker( at java.util.concurrent.ThreadPoolExecutor$ at

Contributor III

I don't know that this is the issue, but it may be related. We've had timing issues when enrolling Mojave Macs without DEP (we don't use DEP for all devices yet) if we sort of speed through setup assistant and enroll. If we wait a few mins after completing the setup assistant and THEN enroll - no probs at all. It feels like something (certs?) are pushed from Apple on first login and those seem to take a few mins to arrive. Not sure how to deal with this relating to DEP - we can just wait 5 mins before enrolling, but that's not an option with DEP!

Good luck!



Have you tried running Wireshark? See if everything is reaching where it's supposed to?

Unable to send push notification com.jamfsoftware.jss.pushnotification.notifications.AppleMDMCheckInNotification@3740501a.

This could be a network issue. Also, have you downloaded the Push Diagnostics app from two canoes? That could also help you troubleshoot.