Machines re-naming themselves. Name (number)

Contributor II
Contributor II

So, I wasn't too sure what to title this.
It's the issue where a machine will give itself a number on the end of its bonjour name whenever it switches between wireless or ethernet.
I'm not quite knowledgable on how OS X communicates with DNS/DHCP if there is something in there that I am missing that causes it, or if it is something in the OS that can be altered. Needless to say it's rather annoying when I have a bunch of machines on my network with numbers after the name.


New Contributor

I am seeing this, too, and am wondering, what to do about it. At least the .local style Bonjour domain name appears to remain unchanged.

Valued Contributor

That's frequently a side effect of the "Bonjour Sleep Proxy," which is enabled with the "Wake for network access" checkbox under Energy Saver.

The short explanation is that upon computer sleep, the sleep proxy server (usually the AP or router) begins identifying itself as that computer to the network. Once the device wakes, the sleep proxy server stops identifying itself as the computer and everything is fine. If, however, the sleep proxy doesn't know that the computer woke up (it was on another network, or connected to Ethernet and WiFi is off, etc.), it will assume the computer is still asleep. If the computer then reconnects to the network, its name will already be taken by the sleep proxy, so it adds a (2) and moves on.

Valued Contributor

@bvrooman and @Simmo have either of you found a cure for this? Is there anything we can actually do about it? We are seeing a larger number of devices having this issue and I am not sure if we should bother correcting the names in the JSS or not. The past couple of weeks I have made it an effort to update the computer name record. I'm not sure it is worth my time to chase these down.