macOS Monterey - LoginWindow defaults to name and password

DennisMX
Contributor II

We have a configuration profile that configures all macbooks to display a list of the local users.
This is working as expected in all OS'es, but when upgrading to Monterey the loginwindow now defaults to requiring a username and password.

In the GUI of macOS it looks a bit weird, also on Catalina and BigSur, where the bullet is set to 'name and password', but still the policy is working and you only have to enter your password in the login screen.

When i exclude a Monterey machine from that policy the option is available, but selecting 'List of Users' doesn't change anything to the login screen.

Anyone experience the same issue or know where to check for possible causes?

10 REPLIES 10

chrisB
Contributor

DennisMX
Contributor II

@chrisB Do you experience this on Intel and M1 macbooks?

We have a small test group for Monterey and the Intels seem to work as expected, the M1 macbooks are facing this issue.

chrisB
Contributor

I found the problem on a new iMac (24", M1, 2021) and did the tests only with this one.

Since 90% of our Mac fleet are Intel Macs and no negative feedback has been received so far, I suspect (also) that it only affects devices with Apple Silicon (M1 and newer).

DennisMX
Contributor II

@chrisB Did you find a policy / profile that causes this or just enrolling an M1 results in the missing user in the loginwindow?

chrisB
Contributor

We have a configuration profile for "Login Window" which is set to show the "List of users able to use these computers".

DennisMX
Contributor II

@chrisB Which options did you enable in that section?
We have "List of users able to use these computers" with the option "Show local users" enabled for all of our machines (Intel/M1, Catalina, BigSur and Moneterey) and only Monterey on M1 requires the user to type the username every time.

Also disabling this policy and have the user configure it locally still reuires the user to enter the username manually

We have the following settings for the "Login Window" configuration profile:

01.png

02.png

03.png

DennisMX
Contributor II

@chrisB After enabling the option to also show Computer admins it finally worked.
Maybe i missed this new behaviour...
Thanks for replying!

DennisMX
Contributor II

hmzzz
I will keep an eye on the M1's with Moneterey