MacOS update fails

rambro
New Contributor II

I have not been able to get macOS to update on a macbook that is enrolled in JAMF. These are all DEP enrolled machines I get the attached error right before the reboot. I was able to do it on a newly wiped machine but i did it right away when logging in the first time. So the configuration profiles had not been applied yet. What could be blocking the update from installing?

d18497eeec204e4c8a600aad6241f73d

8 REPLIES 8

maheshveldandi
New Contributor III
New Contributor III

Please Check the File-vault-2 On or Off. If File-vault-2 is enable it will not allow to upgrade the macOS.
Choose Apple menu () > System Preferences, then click Security & Privacy.
Click the FileVault tab.
Click Locked, then enter an administrator name and password.
Click Turn On/Off FileVault.

rambro
New Contributor II

So we will have to decrypt all our Macs to do MacOS updates?

bvrooman
Valued Contributor

What? That is definitely not the case; you can upgrade an encrypted Mac all day long.

When you open the OS install app, choose "Installer Log" from the Window menu and then pick "Show All Logs" from the dropdown. That might give you some indication what is happening right before you see that error message.

hkabik
Valued Contributor

Is it being installed from an Admin or standard account? If standard, does it work if you try it on an admin account?

garybidwell
Contributor II

Do you have a active internet connection. As I found on updating my own machine at home from a copy of Mojave’s I downloaded earlier in the office, it wouldn’t start the process unless I joined my WiFi so it talked to Apple servers to validate the install.
Also the first part of the process is it creates a temporary recovery partition to copy the installer files. As bvrooman mentioned the installer logs will show its its failing to create this (btw; with no internet connection it falsely reported that it couldn’t covert the disk to APFS format - even though it was already APFS)

lgt28jr
New Contributor II

have you checked the time & date are correct on the system

jmariani
Contributor

If you have auto proxy configuration enabled, try disabling it and running the installer again.

donald_olson
New Contributor

@rambro Did you ever get this to work?