Mavericks 10.9.2 - OS X needs to repair your Library to run applications

New Contributor

Hello Everyone,

We just updated all our school computers to Mavericks to be able to run the state tests and we found that every time a new user logs in is getting the error and can't do anything. New computers (3years olds or less) work fine but all other Macbooks and MacBoosPro are getting the error.

I found a few scripts that may fix but only for 1 user, so we have multiple kids using the computer one day. We don't use OD, we have only AD. Local accounts work fine but we need it network accounts to work.

Snow leopard works perfect but we need latest JAVA version so that's why we move to Mavericks.

Thank you.


New Contributor

Tried both before but still getting the error.

we added the sudo update_dydl_shared_cache -root / @login command and same error.

I'm using an admin user to repair the library but I got the same message after 30secs.

We have Mavericks 10.9.2 and using Casper 9.3.
Some people mentioned that using last version fixes the error but not with us.

Thank you

New Contributor III

We're having the same problem. Any update?

New Contributor

My fix for this issue was per-user only, so many not be applicable to your environment.

I logged in as an administrator user, then re-applied all ACLs to the affected user's home directory.

The resetpassword utility should do this (in my mind) but it did not work for me.

Valued Contributor

The only way to resolve this is to go through anything that's FEU or FUT...

This is time consuming but does resolve the issues..

I believe that the individuals who packaged the apps did so while bound to AD and logged on as thmeselves, thius, The pref files were being written to the Network share home and clearly this caused issues..

I've been there, done that.. and all is now well with the world.!

Esteemed Contributor II

Possible fix here.