MDM client - invalid auth token?

New Contributor III

So I think this might explain some of my mixed results, but not sure how to go about verifying it.. Checking the console of one of the lab workstations I have found ...

9/13/13 8:06:50.325 AM mdmclient: ** ERROR ** [Agent:238250356] Unable to proceed with connection to: https://JSSURL:8443//computer/mdm (00000000-0000-0000-A000-4A414D460004) because don't have valid MDM AuthToken

9/13/13 8:12:40.759 AM mdmclient: ** ERROR ** [Agent:MDMUserAuthenticator:238250356] Unable to save MDM user AuthToken in keychain: -25299 (The specified item already exists in the keychain.)

9/13/13 8:12:40.975 AM Could not connect the action buttonPressed: to target of class NSApplication
9/13/13 8:12:44.612 AM iCal Helper: Could not find Meta Data for persistent Store
9/13/13 8:12:47.467 AM mdmclient: [Agent:238250356] Processing server request: ProfileList for: <User: 238250356>
9/13/13 8:12:48.570 AM mdmclient: [Agent:238250356] Processing server request: CertificateList for: <User: 238250356>

I ran sudo jamf recon (and had no result), but it seems happier after getting enrolled via the 'quickadd' package



we had this issue before, i can't remember how we fixed it, but make sure you have access through your firewall to apple's subnet, try removing the jamf removeFramework and re-enroll it, possibly.

New Contributor II

Had similar problem, token was denied as invalid CSFR token.  Was a firewall issue. On an iPad through LTE, token was accepted w/o problems.