MS Defender Full Disk Access not deploying

New Contributor

Trying to get Defender deployed to our macs. Everything seems to work except for PPPC for Full Disk Access, so I can't get Defender to show its licensed.

Followed the guide at MS and get the following error with Step 6

In the payload (UUID: 551B3172-1B04-4B74-85CA-87F7844CD9B6), the key 'CodeRequirement' has an invalid value.

Bonus Question - Configuring background services - what is the proper preference domain to use?



Contributor III

We deploy the same config for defender, it mostly works. My hunch is, where it doesn't something else has gone wrong with the Mac processing config profiles. If you are a jamf customer, ask them to run a report looking for RemoveProfile loops, you can also ask them to delete any "deleted" profiles as deleting them in the client doesn't actually remove them...

As to your extra question, we disable all background notifications -

New Contributor


and it looks like i either had a space or the original documentation had something incorrec.t pulled the code requirement from the github repo and that one worked

which code did you get from Git Hub?

New Contributor

Hi, gd1107. How did you get Microsoft Defender uploaded? I am trying to add the Microsoft Defender for endpoint package to jamf school and keep getting a cant parse XML file when uploading the package. I tried using Composer to repackage the file. When I try to install the repackage file, It fails out and won't install.