Multiple machines not checking in

Musicmaker
Contributor

I've read multiple posts here about machines not checking in with the JSS anymore.

We have multiple machines that are not checking in anymore with our cloud JSS.
I've tried many things written in previous posts. These are the commands I've tried and the results:
Command: sudo jamf enroll -prompt
Result: 

Downloading required CA Certificate(s)...

Restoring JAMF.keychain since an error occurred.

Error submitting enrollment status to the JSS: Security Error - A security error has occurred.

There was an error.

     Error enrolling computer: Unable to establish trust with the JSS - Unable to add the certificates to the System keychain...

Command: sudo profiles renew -type enrollment
Result: 

Error: Renewing DEP enrollment failed: (null) (NSCocoaErrorDomain:4099)

When computers are connected to our education network I connect to them with ssh. This is how I tried these commands. I prefer to do it like this (when renewing through Jamf doesn't work), because I don't have to disturb those employees (mostly teachers). Of course we can call them to make an appointment and do a re-enroll on the macBook, but I rather do this without users being disturbed. And it applies to multiple macBooks.

On one macBook I removed the Jamf framework. When starting the renew the MDM profiles the user is prompted and has to choose 'update'. I spoke to this user and she saw the notification and because of the fact that she didn't know what is was, she would not click on it. So I want to prevent situations like this.
Better; prevent macBooks from not checking in anymore. 

2 REPLIES 2

dpwlg
New Contributor III

Did you ever find a solution to this?

gmusland
New Contributor II

I am having this trouble too. I have heard - only you - exclusive to my environment.