Netboot Issues

New Contributor

Hi Every,

I'm hoping someone may have some ideas on if anything network related could be causing issues with netboot working. I'm setting up a new server at an office that the network isn't setup like our normal offices and I'm suspecting it may be causing issue, but haven't been able to determine why yet. Looking at the logs, I'm not even seeing the server receive a request from the clients.
- The server is setup the exact same as other offices that work fine.
- Server is on the same subnet as the clients.
- Looking at the logs on the server I'm not seeing any mention of a client request or anything for netboot other then logs of it being enabled.
- I also tried adding the netboot onto another system just to make sure it's not an issue with that system.
- I've updated to 10.11.6 since there were some issues with 10.11.4, but that didn't help either.

We also had some issues with our PXE setup working that we had to work around using DHCP option, that makes me suspect the network even more, but still haven't found an option for the netboot side.

Has anyone seem something similar before?




Contributor III

Seems like it's not bouncing to all the subnets correctly. I worked with our telecom group to get three NETSUS's added and they use a program called IP Helper to push the IP across subnets. We actually have it so only certain regions can see the NETSUS. So each NETSUS covers a certain area.

Not applicable

IP helper only jumps subnets, we're on that part. The issue is the Cisco 7000 Nexxus router

New Contributor

You are exactly right. They are using a Cisco 9000 Nexxus. One of my other network admins was able to find a way to add relays onto the vlan that seems to have helped. Appears these switches don't fully support this function.

Valued Contributor

Please have a look of the network port config of the Cisco switch you are connected.
'dhcp snooping' has to be trusted on that port to do BSDP/DHCP traffic to the NetBoot server.

Cisco command for the switchport where NetBoot server is connected:

ip dhcp snooping trust