Netboot Server Failing


Hey folks,

I seem to be getting nowhere with this, so I was wondering if anybody else had come across the same...

We have three different campuses at our University, all of which have their own Netboot server that runs the Jamf NetSUS software (via Ubuntu). These generally work perfectly, however as of last week, attempting to Netboot to one of the campus servers now results in a grey progress bar that sits and goes nowhere. All other servers remain fine, and the problem persists across a variety of Mac and Macbook hardware at that campus.

I have attempted the following to remediate thus far along with the usual restarting of services and the server itself:
- Updating the NetSUS application to the latest version
- Copying a known-working .nbi file from one of our functional Netboot servers and configuring the faulty server to use that one (still the same problem)
- Checking with the network team to see if any changes have been made (they are adamant none have...)
- Enabling verbose mode on a Mac and running a test boot

That last step shows the Mac failing on the following line every time:

Initialized /dev/rdisk4 as a 5 MB case-insensitive HFS Plus volume

Am I right in thinking it can't be a network problem at this point, as the nbi file appears to be downloaded and the Mac is trying to mount and install at this stage?

Picture attached with the full output (apologies for the state of the Mac, it's one of our student loan units...), and thanks for any help!



Contributor III

Does the problem remain if you use a different netbook image.
Have you cleared out the Netboot cached images and restarted the netbook service on the server?
If not might be worth checking that the ip helper protocol on the network is forwarding the server IP properly.


Hey there, thanks for the response!

How would I go about clearing out the cached images? Or do you mean literally just deleting the existing .nbi files from the Netboot directory?

In terms of the rest, I have tried copying over a High Sierra .nbi that I know is functioning fine on the other server, but the outcome is still the same. I'll try switching back to an older .nbi and test that.

I have restarted services umpteen times, upgraded the NetSUS/Netboot install to the latest version, restarted the server, etc, all to no avail. The network team are adamant the IP Helpers are set up correctly on each campus.

Totally stuck with where to go on this. If I'm reading the output correctly in the screenshot, it's finding the file just fine and downloading it, so I presume everything has to be ok with IP Helpers and DHCP at that stage?

Contributor III

Sounds like the network aspect is ok if it sees the Netboot image when holding down alt (presume it does right). Might still be worth making sure that the IP helpers are correctly configured.
Does it make a difference if you serve the image over http or NFS?

Not much to the netbook cache. Go /Library/Netboot/NetbootClients0/ and delete all the contents (usually contains all the instances of previous netbook images).

Lastly, check that the appropriate ports are configured to work with the protocol you are using:


I'll try those tips tomorrow, thanks again!