NetSUS Branch URL creation "Not Found"

New Contributor III

Whenever I create a branch in the NetSUS appliance, I test it by copying the URL into a new window, and I always get a "The requested URL /content/catalogs/index_catalogs/others/index-mountainlion-lion-snowleopard-leopard.merged-1_test.sucatalog was not found on this server" error.

Obviously this means the client won't work either, I can verify the URL of my old SUS just fine, it displays the XML no issue. Any reason as to why catalogs I am making in this appliance aren't working?


Legendary Contributor III

That URL doesn't look right to me. Is that the actual error you get, copied and pasted?
It shouldn't be "/content/catalogs/index_catalogs/others/index" it should be "/content/catalogs/others/index-"

You have an "index_catalogs" section in the middle there that is likely throwing it off.

Can you post some of the settings as they appear on your appliance?

New Contributor III

So none of this is in production and I can wipe/add anything, I've been following the guide for the appliance, but I do not understand the best practices for adding branches.

I was under the impression I could just create two branches, one called "test" and the other "production" When I do I get the following URL's generated for me:

FYI: This is my base URL:

Neither of those work in the browser, I get the same 404 error. I thought maybe it's because I need to follow the proper URL config for Mountain Lion, Lion, etc that includes the long "merged" URL, but I still get the same 404, this seems more like a configuration/permissions error on my end, but I have no idea where, or how to fix it.

Legendary Contributor III

So using the above, have you tried the following URLs in a browser?

Based on how I see the URLs get set up, those should work, provided there are no configuration issues, as you say. I do see your URL is using SSL (https) Are you certain its set up properly for that? You can try the same URLs as above but with http instead to see if you can pull them up.

Finally, if you haven't done so already, look at the reposado github page. I find the included documentation in the NetSUS appliance too slim. The project page has better information about branches and how they work.

New Contributor III

New Contributor II

Did you find the resolution? I have the same problem as yours.

  1. You can't browse to an htaccess URL-rewritten site in a browser - the only client meant to work to access the 'expanded' URL is the softwareupdate binary. Complicating matters is the fact Mavericks can't use the old --CatalogURL testing method, so you should be setting it for the system with ``` sudo defaults write /Library/Preferences/ CatalogURL "" ``` and then running softwareupdate -l
  2. Without providing a valid cert(or seeding it on client workstations,) https will fail from the client with this (somewhat obvious) error:
    Finding available software
    The certificate for this server is invalid. You might be connecting to a server that is pretending to be “” which could put your confidential information at risk.

So the GUI may not be lying to you about what the 'index' URL should be, but it doesn't mean the service is 100% functional for both the cert reason and the fact rewrites seem borked - for example the test listed here: doesn't seem to be working:

curl --user-agent "Darwin/13"
<title>404 Not Found</title>
<h1>Not Found</h1>
<p>The requested URL /content/catalogs/index_test.sucatalog was not found on this server.</p>
<address>Apache/2.2.22 (Ubuntu) Server at Port 80</address>

New Contributor III

Hi All,
were you able to sort this issue? I do see the same issue. Till last week I am able to view content in branch URL , now it is no more?

any suggestions please?