NetSUS NetBoot Server will not start

New Contributor

I have deployed the appliance to a production vSphere 5.1 environment.
I have uploaded the nbi file and set the subnet to ( )
The ip address of the NetSUS appliance is so it's in the same subnet.
I can not get the NetBoot service to enable.

Am I missing something or can't the NetSUS appliance handle non standard subnets ?


Honored Contributor II
Honored Contributor II

I've had trouble with this in the past and it has normally been subnet related, although we do have a few sites with complex subnets working ok.

The only other possibility is that it doesn't like the nbi that has been uploaded. Are there any spaces in the nbi name?

New Contributor

I have tried the nbi file that I've been using successful from an OSX server plus I created a new one just in case.

The file name was casper1.nbi so less than 8 characters. no spaces or non alphanumeric characters.

I will simplify the name further and see if that works.

Thanks for letting me know that the subnet should work.

New Contributor

Created a new nbi file called C1.nbi using Casper NetInstall Image Creator 5.0 from a base OSX 10.9.5 dmg created using the "Build OS Package" in Composer 9.62.

Settings used were;

Image Name = C1
Image Index = 1101
Enable this NetInstall Image = True
Set this NetInstall Image as the Default Image = true
Compress image = true ( tried false last time )
Added the 9.62 casper imaging app
Created Casper Preference file
added the correct JSS url

NetBoot will not enable. In /var/log/auth.log on the NetSUS appliance I can see "setnbiimages C1.nbi"

Also tried a simple subnet but NetBoot will not enable

Contributor III

I'm not doing much with NetSUS at work as our (currently) supported client range is too broad (benefits from multiple NBI's and filtering). I did mess around with NetSUS 3.02 briefly at home this weekend. vSphere 5.5 with Ubuntu 14.04 and CentOS 7. Ubuntu worked straight away with NetBoot enabling/disabling as expected. CentOS was quirky and would enable but not disable NetBoot. NetBoot on CentOS 7 also didn't remain enabled/persist across reboots in limited testing (dhcpd.service likely not enabled @ boot)

New Contributor

I am admitting defeat after spending a lot of time trying to get this to work.

I have gone back to a physical mac running server which works reliably all the time.

The NetSUS concept is a great idea but after many hours of playing with it I could get it to work occasionally but I never worked out why and it wasn't stable.

Restarting AFP seemed to work 1 out of 10 attempts. eg restart AFP then enable netboot.

Simply to unreliable and time consuming for a production environment with, I'm guessing here, complex subnets.